summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPim Otte2015-11-08 21:37:40 +0100
committerPim Otte2015-11-08 21:37:40 +0100
commit8159fee7d30a11af81487b0568f37c5a9ba85b51 (patch)
tree3251f82935a8240426cfcc9fd6adc5ab39e1cebb
downloadaur-8159fee7d30a11af81487b0568f37c5a9ba85b51.tar.gz
Initial commit (since AUR 4)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..893a87d152e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = syncany-git
+ pkgdesc = Cloud storage and filesharing application with a focus on security and abstraction of storage.
+ pkgver = 0.1.8.alpha.g95a5172
+ pkgrel = 1
+ url = https://www.syncany.org/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = java-runtime>=7,
+ depends = bash-completion
+ source = syncany-git::git+http://github.com/syncany/syncany
+ md5sums = SKIP
+
+pkgname = syncany-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df0888e8d6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Armin Fisslthaler <armin@fisslthaler.net>
+pkgname=syncany-git
+pkgver=0.4.8.alpha.g194955d
+pkgrel=1
+pkgdesc="Cloud storage and filesharing application with a focus on security and abstraction of storage."
+arch=(any)
+url=https://www.syncany.org/
+license=(GPL3)
+depends=('java-environment>=7', 'sh')
+optdepends=('bash-completion: auto completion in bash')
+makedepends=(git)
+conflicts=('syncany')
+source=("${pkgname}"::'git+http://github.com/syncany/syncany')
+md5sums=('SKIP')
+
+pkgver(){
+ cd "$srcdir/$pkgname"
+ echo $(grep 'applicationVersion =' build.gradle | cut -d'"' -f2 | sed 's/-/./g').g$(git rev-parse --short HEAD)
+}
+
+build(){
+ cd "$srcdir/$pkgname"
+ ./gradlew installApp
+}
+
+package(){
+ install -Dm755 "$srcdir/$pkgname/gradle/arch/syncany/syncany" "${pkgdir}/usr/bin/syncany"
+ install -Dm755 "$srcdir/$pkgname/gradle/bash/syncany.bash-completion" "${pkgdir}/etc/bash_completion.d/syncany.bash-completion"
+ install -Dm755 "$srcdir/$pkgname/gradle/systemd/syncany.service" "${pkgdir}/usr/lib/systemd/user/syncany.service"
+ install -Dm755 "$srcdir/$pkgname/gradle/systemd/syncany-gui.service" "${pkgdir}/usr/lib/systemd/user/syncany-gui.service"
+
+ cd "$srcdir/$pkgname/build/install/syncany/lib"
+ for jar in *; do
+ install -Dm644 "$jar" "${pkgdir}/usr/share/java/syncany/$jar"
+ done
+}