summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien Dubosson2015-05-29 13:15:14 +0200
committerFabien Dubosson2015-05-29 13:15:14 +0200
commit5e057cd69519ba3e903227375a821d5a04c0219b (patch)
treea7615e58a8b458b2e95d5ae5df5e3d352eb470b2
downloadaur-5e057cd69519ba3e903227375a821d5a04c0219b.tar.gz
Move 'synchost-git' into separate repo for AUR4
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD30
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eda1b836e847
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = synchost-git
+ pkgdesc = A command-line tool to keep an host synchronized
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/StreakyCobra/synchost
+ changelog = ChangeLog
+ arch = any
+ license = MIT
+ depends = git
+ depends = python>=3.4
+ depends = python-termcolor
+ provides = synchost
+ conflicts = synchost
+ source = synchost::git+https://github.com/StreakyCobra/synchost.git#branch=develop
+ md5sums = SKIP
+
+pkgname = synchost-git
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..97e4a656e1e6
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,4 @@
+2014-07-30 Fabien Dubosson <fabien.dubosson@gmail.com>
+
+ * 0.0.1-1 :
+ Package created
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da115b12376c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Fabien Dubosson <fabien.dubosson@gmail.com>
+
+pkgname="synchost-git"
+_pkgname="synchost"
+pkgver="0.0.1"
+pkgrel="1"
+pkgdesc="A command-line tool to keep an host synchronized"
+url="https://github.com/StreakyCobra/synchost"
+license=('MIT')
+arch=('any')
+depends=('git' 'python>=3.4' 'python-termcolor')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+changelog="ChangeLog"
+source=("${_pkgname}::git+https://github.com/StreakyCobra/${_pkgname}.git#branch=develop")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}/"
+
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=4 sw=4 et: