summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2016-06-20 19:48:20 -0400
committerKevin MacMartin2016-06-20 19:48:20 -0400
commitb4448b87cf7c3a2b75cac109c8e9dd0460d406fa (patch)
tree92089c07312dd6a1de732efbfbdbd5f36197bb5a
parent85d0c10e3fe800814eb7711507fe0d4a89cfdb55 (diff)
downloadaur-b4448b87cf7c3a2b75cac109c8e9dd0460d406fa.tar.gz
Switch to syncthing repo, update to release version 0.13.7, add epoch to push version above old git version, update gitignore to reflect changes, include AUTHORS list with the LICENSE, add README to a doc folder, update systemd service to reflect changes to initialization, and add a note about where it expects the SSL certificate and key
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore31
-rw-r--r--PKGBUILD30
-rw-r--r--syncthing-discosrv.install3
-rw-r--r--syncthing-discosrv.service3
5 files changed, 30 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb1a33ea8d06..cf15aa483a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
# Generated by mksrcinfo v8
-# Tue May 31 00:55:41 UTC 2016
+# Mon Jun 20 23:47:56 UTC 2016
pkgbase = syncthing-discosrv
pkgdesc = Discover server for the syncthing P2P synchronization utility
- pkgver = 20160527.r71.60c7dee
+ pkgver = 0.13.7
pkgrel = 1
+ epoch = 1
url = http://syncthing.net
install = syncthing-discosrv.install
arch = i686
@@ -17,11 +18,11 @@ pkgbase = syncthing-discosrv
makedepends = godep
makedepends = mercurial
depends = glibc
- source = git+https://github.com/syncthing/discosrv.git
+ source = https://github.com/syncthing/syncthing/archive/v0.13.7.tar.gz
source = syncthing-discosrv.service
source = syncthing-discosrv.tmpfiles.conf
- sha512sums = SKIP
- sha512sums = b0f64ce7f6b6ca97b759dd2ccc8df44acb06a612800c37a2dae3dd6c54b0f524950c70b21fd965b28e2a1dd4b0ca48c6b39e9b2ae67e0f7f093f8f92cb221402
+ sha512sums = 8e00355f9774329cb4da1173ad27528213520644c32d5b5ba2345b93787bc762d0498c33ccf2d72e91b770258e8a55d86573934baeff0bc0799416850320c82b
+ sha512sums = b2a8daa48be57ad47542569473128c8590d4bbe124de0912ce5b3de7deb1b54dd0d3ed66e925fc11addded075d24d6a1fe822d71338d128b7ca03fd43c082d8c
sha512sums = 28b0bb6a6f2fa536ec8cb887cfebf4706be25af5e29da39e2e3776daeeeb48f75fb5be255472920355948d8905830342866e89299facd626ddf8a658d84faf27
pkgname = syncthing-discosrv
diff --git a/.gitignore b/.gitignore
index 2bee04f33471..f2f999cf58bd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,32 +1,5 @@
+*.tar.gz
*.pkg.tar.xz
pkg
src
-discosrv
-go-lz4
-go.text
-goleveldb
-groupcache
-logger
-luhn
-pkg
-protocol
-ratelimit
-snappy
-src
-suture
-syncthing
-xdr
-b
-bufs
-crypto
-du
-exp
-fileutil
-lock
-mathutil
-pq
-ql
-relaysrv
-sortutil
-strutil
-zappy
+remakepkg
diff --git a/PKGBUILD b/PKGBUILD
index dc70eb9cc860..7952b0b76ce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
_pkgname=syncthing
pkgname=$_pkgname-discosrv
-pkgver=20160527.r71.60c7dee
+epoch=1
+pkgver=0.13.7
pkgrel=1
pkgdesc='Discover server for the syncthing P2P synchronization utility'
url='http://syncthing.net'
@@ -13,24 +14,18 @@ makedepends=('git' 'go' 'godep' 'mercurial')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
source=(
- 'git+https://github.com/syncthing/discosrv.git'
+ "https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz"
"$pkgname.service"
"$pkgname.tmpfiles.conf"
)
sha512sums=(
- 'SKIP'
- 'b0f64ce7f6b6ca97b759dd2ccc8df44acb06a612800c37a2dae3dd6c54b0f524950c70b21fd965b28e2a1dd4b0ca48c6b39e9b2ae67e0f7f093f8f92cb221402'
+ '8e00355f9774329cb4da1173ad27528213520644c32d5b5ba2345b93787bc762d0498c33ccf2d72e91b770258e8a55d86573934baeff0bc0799416850320c82b'
+ 'b2a8daa48be57ad47542569473128c8590d4bbe124de0912ce5b3de7deb1b54dd0d3ed66e925fc11addded075d24d6a1fe822d71338d128b7ca03fd43c082d8c'
'28b0bb6a6f2fa536ec8cb887cfebf4706be25af5e29da39e2e3776daeeeb48f75fb5be255472920355948d8905830342866e89299facd626ddf8a658d84faf27'
)
-pkgver() {
- cd discosrv
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
build() {
- cd discosrv
-
+ cd $_pkgname-$pkgver/cmd/discosrv
export GOPATH="$srcdir"
go get -d -tags purego
@@ -50,8 +45,17 @@ build() {
}
package() {
+ # Install systemd service and tmpfiles config
install -Dm644 $pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
install -Dm644 $pkgname.tmpfiles.conf "$pkgdir"/usr/lib/tmpfiles.d/$pkgname.conf
- install -Dm755 discosrv/discosrv "$pkgdir/usr/bin/$pkgname"
- install -Dm644 discosrv/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Install license and list of authors
+ cd $_pkgname-$pkgver
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 AUTHORS "$pkgdir/usr/share/licenses/$pkgname/AUTHORS"
+
+ # Install documentation and binary
+ cd cmd/discosrv
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm755 discosrv "$pkgdir/usr/bin/$pkgname"
}
diff --git a/syncthing-discosrv.install b/syncthing-discosrv.install
index 91045c0d1da3..1a2e20b8957b 100644
--- a/syncthing-discosrv.install
+++ b/syncthing-discosrv.install
@@ -10,6 +10,9 @@ post_install() {
# Setup the systemd tmpfiles
systemd-tmpfiles --create syncthing-discosrv.conf
+
+ printf '\n%s\n' 'Syncthing expects an SSL certificate and key located at'
+ printf '%s\n' '/var/discosrv/cert.pem and /var/discosrv/key.pem'
}
post_upgrade() {
diff --git a/syncthing-discosrv.service b/syncthing-discosrv.service
index 8e75af27cef2..f2fd6415572d 100644
--- a/syncthing-discosrv.service
+++ b/syncthing-discosrv.service
@@ -5,7 +5,8 @@ After=network.target
[Service]
User=syncthing
Group=syncthing
-ExecStart=/bin/sh -c "/usr/bin/syncthing-discosrv -db-dsn='file:///var/discosrv/discosrv.db'"
+WorkingDirectory=/var/discosrv
+ExecStart=/usr/bin/syncthing-discosrv -db-dsn='file:///var/discosrv/discosrv.db'
Restart=on-failure
SuccessExitStatus=2