summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2020-08-16 23:54:15 -0400
committerKevin MacMartin2020-08-16 23:54:15 -0400
commitcf1704dc9382fe18b3052e31b544764cc6719b65 (patch)
treee0e593a624e1c8f4a6766a01e59cc6eafa1da3a6
parent21aa4544a04e21c9beb143c50df05441c0e2b111 (diff)
downloadaur-cf1704dc9382fe18b3052e31b544764cc6719b65.tar.gz
Add a flag that keeps the temporary directories read write so they can be deleted with rm -rf (thanks mqs!)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c59e58815c31..3ee409eea8bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syncthing-discosrv
pkgdesc = Discover server for the syncthing P2P synchronization utility
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://syncthing.net
install = syncthing-discosrv.install
diff --git a/PKGBUILD b/PKGBUILD
index 726dcfdf7b76..5a6bbb7e4645 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Kevin MacMartin <prurigro@gmail.com>
# Contributor: Iiridayn
# Contributor: hucsmn
+# Contributor: mqs
_binname=stdiscosrv
_pkgname=syncthing
pkgname=$_pkgname-discosrv
epoch=1
pkgver=1.8.0
-pkgrel=1
+pkgrel=2
pkgdesc='Discover server for the syncthing P2P synchronization utility'
url='http://syncthing.net'
license=('MIT')
@@ -33,13 +34,13 @@ prepare() {
install -d src/github.com/$_pkgname
mv $_pkgname-$pkgver src/github.com/$_pkgname/$_pkgname
cd src/github.com/$_pkgname/$_pkgname
- go mod vendor
+ go mod vendor -modcacherw
}
build() {
export GOPATH="$srcdir"
cd src/github.com/$_pkgname/$_pkgname/cmd/stdiscosrv
- go build -x -i -v -ldflags -w
+ go build -modcacherw -x -i -v -ldflags -w
}
package() {