summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2021-03-31 22:05:24 +0200
committerMorten Linderud2021-03-31 22:05:24 +0200
commit1dcbcad06c62d7a3166b15191dafa69dd475f453 (patch)
treec1ade417642f8be99d0949bb0c7b6b627c2b9752
downloadaur-1dcbcad06c62d7a3166b15191dafa69dd475f453.tar.gz
import from community
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
-rw-r--r--kde-statusicon.patch44
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bbeaa96fc0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = syncthing-gtk
+ pkgdesc = GTK3 based GUI and notification area icon for Syncthing
+ pkgver = 0.9.4.4
+ pkgrel = 2
+ epoch = 1
+ url = https://github.com/syncthing/syncthing-gtk
+ arch = any
+ license = GPL2
+ makedepends = python2-setuptools
+ depends = syncthing>=0.14.50
+ depends = gtk3
+ depends = libnotify
+ depends = python2-bcrypt
+ depends = python2-cairo
+ depends = python2-dateutil
+ depends = python2-gobject
+ source = syncthing-gtk-0.9.4.4.tar.gz::https://github.com/syncthing/syncthing-gtk/archive/v0.9.4.4.tar.gz
+ source = kde-statusicon.patch
+ sha256sums = 896ddaaba4ad0b8f090c5a381a28b3da759932314562cdd50ca288543b03ddcc
+ sha256sums = 109d8c970045e60251fc64865f05322b23a0995ee6725be02905941cb3a1ae0d
+
+pkgname = syncthing-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..089615b22545
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Martin Wimpress <code@flexion.org>
+# Contributor: kozec <kozec at kozec dot com>
+
+pkgname=syncthing-gtk
+pkgver=0.9.4.4
+pkgrel=2
+epoch=1
+pkgdesc='GTK3 based GUI and notification area icon for Syncthing'
+arch=('any')
+url='https://github.com/syncthing/syncthing-gtk'
+license=('GPL2')
+depends=('syncthing>=0.14.50' 'gtk3' 'libnotify' 'python2-bcrypt'
+ 'python2-cairo' 'python2-dateutil' 'python2-gobject')
+makedepends=('python2-setuptools')
+source=($pkgname-$pkgver.tar.gz::https://github.com/syncthing/$pkgname/archive/v$pkgver.tar.gz
+ kde-statusicon.patch)
+sha256sums=('896ddaaba4ad0b8f090c5a381a28b3da759932314562cdd50ca288543b03ddcc'
+ '109d8c970045e60251fc64865f05322b23a0995ee6725be02905941cb3a1ae0d')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Enable Gtk.StatusIcon in KDE
+ patch -Np1 -i ../kde-statusicon.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
diff --git a/kde-statusicon.patch b/kde-statusicon.patch
new file mode 100644
index 000000000000..cd736324bd7a
--- /dev/null
+++ b/kde-statusicon.patch
@@ -0,0 +1,44 @@
+From be3d197db4c7f7b06c88fa7457f27bb7741cd016 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
+Date: Fri, 26 Jan 2018 19:18:34 +0100
+Subject: [PATCH] Enable Gtk.StatusIcon in KDE
+
+---
+ syncthing_gtk/statusicon.py | 10 ++--------
+ 1 file changed, 2 insertions(+), 8 deletions(-)
+
+diff --git a/syncthing_gtk/statusicon.py b/syncthing_gtk/statusicon.py
+index 5f19ee9..b4f7d10 100644
+--- a/syncthing_gtk/statusicon.py
++++ b/syncthing_gtk/statusicon.py
+@@ -26,7 +26,7 @@
+ # StatusIconKDE4 | excellent | usable³ | very good⁵ | usable³ | usable³ | excellent | excellent |
+ # StatusIconQt5 | very good (KF5) | - | - | - | - | - | - |
+ # StatusIconAppI | good² | none | excellent | none | none | excellent | good² |
+-# StatusIconGTK3 | none | excellent | none | very good¹ | very good¹ | none | good⁴ |
++# StatusIconGTK3 | good | excellent | none | very good¹ | very good¹ | none | good⁴ |
+ #
+ # Notes:
+ # - StatusIconQt5:
+@@ -211,12 +211,6 @@ def __init__(self, *args, **kwargs):
+ # Unity fakes SysTray support but actually hides all icons...
+ raise NotImplementedError
+
+- if IS_KDE:
+- # While the GTK backend works fine on KDE 4, the StatusIconKDE4 backend will achieve better
+- # results and should be available on any standard KDE 4 installation
+- # (since several KDE applications depend on it)
+- raise NotImplementedError
+-
+ self._tray = Gtk.StatusIcon()
+
+ self._tray.connect("activate", self._on_click)
+@@ -246,7 +240,7 @@ def _on_embedded_change(self, *args):
+ # by a fallback icon
+ is_embedded = self._tray.is_embedded() or not self._tray.get_visible()
+ # On some desktops, above check fails but tray is always visible
+- is_embedded = is_embedded or IS_LXQT or IS_CINNAMON
++ is_embedded = is_embedded or IS_KDE or IS_LXQT or IS_CINNAMON
+ if is_embedded != self.get_property("active"):
+ self.set_property("active", is_embedded)
+