summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2024-03-11 00:29:56 +1000
committercorey drew bruce2024-03-11 00:29:56 +1000
commit731d4135eceb0230bf89baec306a5b2d9d310d25 (patch)
treefa4181fb73437a8aef72165a7935d1512a992fd5
downloadaur-731d4135eceb0230bf89baec306a5b2d9d310d25.tar.gz
Syncthing Deskop 1.0.0-1
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b04dd7b6f33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = syncthingdesktop
+ pkgdesc = Unnofficial Syncthing desktop application
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/twitterdesktop/application
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = unzip
+ depends = libelectron
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ depends = git
+ depends = syncthing
+ source = https://gitlab.com/syncthingdesktop/application/-/archive/1.0.0-1/application-1.0.0-1.tar.bz2
+ sha256sums = SKIP
+
+pkgname = syncthingdesktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..64f071f611f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=syncthingdesktop
+_pkgname=SyncthingDesktop
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Unnofficial Syncthing desktop application"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/twitterdesktop/application"
+license=('GPL')
+depends=('libelectron' 'nss' 'gtk3' 'libxss' 'git' 'syncthing')
+makedepends=('unzip')
+source=("https://gitlab.com/syncthingdesktop/application/-/archive/$pkgver-$pkgrel/application-$pkgver-$pkgrel.tar.bz2")
+sha256sums=('SKIP')
+
+
+package() {
+ cd "$srcdir/application-$pkgver-$pkgrel"
+ chmod +x $pkgname
+ ln -sf "/opt/libelectron/node_modules" "$srcdir/application-$pkgver-$pkgrel"
+ install -dm755 "$pkgdir/opt/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ cp -r ./ "$pkgdir/opt/$_pkgname"
+ cp -r "$pkgdir/opt/$_pkgname/$pkgname.svg" "$pkgdir/usr/share/pixmaps"
+
+
+ # Link to binary
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ # Desktop Entry
+ install -Dm644 "$srcdir/application-$pkgver-$pkgrel/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$pkgname.desktop"
+}