summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-11-03 13:23:48 +0100
committerMartchus2022-11-03 13:23:48 +0100
commit419c9bfbd477a9ce156d014187cef172afced196 (patch)
tree7ed4bc0148a68baa09d0b15ae362430cd6f0d504
parentbf94e65e227dd3e90e5f0c3e8a10b7fc5746c487 (diff)
downloadaur-419c9bfbd477a9ce156d014187cef172afced196.tar.gz
Add patches to fix tests
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e116c6a979bd..9f58634296fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
@@ -34,6 +34,12 @@ pkgbase = syncthingtray
optdepends = kio: KIO plugin for Syncthing actions in Dolphin
optdepends = plasma-workspace: Plasmoid for Plasma 5 desktop
source = syncthingtray-1.3.0.tar.gz::https://github.com/Martchus/syncthingtray/archive/v1.3.0.tar.gz
+ source = https://github.com/Martchus/syncthingtray/commit/f121f5f740d799c2b29e9f5ce8e15ddae7857a28.patch
+ source = https://github.com/Martchus/syncthingtray/commit/ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch
+ source = https://github.com/Martchus/syncthingtray/commit/0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch
sha256sums = aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52
+ sha256sums = 2df0516de56fa279af4fa1f85d524a1aa9e9df4ea3ecd8bacbc146aabf5920d9
+ sha256sums = d6b4af56e0a80d3c813637bc0e9b74dae51f2fbd3919e992a342f9a5abd10acc
+ sha256sums = 763fd7e2804c5bcf2f78ed3fb3669528163f2ba0b0b4d14eda07174932761cc2
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index 46e52e238704..456e808b8a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ _enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
_reponame=syncthingtray
pkgname=syncthingtray
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
@@ -43,13 +43,27 @@ checkdepends=('cppunit' 'syncthing' 'iproute2' 'appstream')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
+ 'https://github.com/Martchus/syncthingtray/commit/f121f5f740d799c2b29e9f5ce8e15ddae7857a28.patch'
+ 'https://github.com/Martchus/syncthingtray/commit/ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch'
+ 'https://github.com/Martchus/syncthingtray/commit/0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch')
+sha256sums=('aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52'
+ '2df0516de56fa279af4fa1f85d524a1aa9e9df4ea3ecd8bacbc146aabf5920d9'
+ 'd6b4af56e0a80d3c813637bc0e9b74dae51f2fbd3919e992a342f9a5abd10acc'
+ '763fd7e2804c5bcf2f78ed3fb3669528163f2ba0b0b4d14eda07174932761cc2')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
}
+prepare() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+
+ patch -p1 -i ../f121f5f740d799c2b29e9f5ce8e15ddae7857a28.patch
+ patch -p1 -i ../ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch
+ patch -p1 -i ../0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch
+}
+
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"