summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-11-03 21:48:04 +0100
committerMartchus2022-11-03 21:48:04 +0100
commit41eca006601765a8944d175655de10e3fb713169 (patch)
tree401e3f5a7d020baa184cbdc329c11670c8116e14
parent419c9bfbd477a9ce156d014187cef172afced196 (diff)
downloadaur-41eca006601765a8944d175655de10e3fb713169.tar.gz
Add further patches for wizard test
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f58634296fc..1dd3f3058e95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
@@ -37,9 +37,13 @@ pkgbase = syncthingtray
source = https://github.com/Martchus/syncthingtray/commit/f121f5f740d799c2b29e9f5ce8e15ddae7857a28.patch
source = https://github.com/Martchus/syncthingtray/commit/ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch
source = https://github.com/Martchus/syncthingtray/commit/0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch
+ source = https://github.com/Martchus/syncthingtray/commit/0ab21657c4feb0500299af79314664b05edfc365.patch
+ source = https://github.com/Martchus/syncthingtray/commit/521567f2350baa1e75a60ad48f5ed7923777b024.patch
sha256sums = aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52
sha256sums = 2df0516de56fa279af4fa1f85d524a1aa9e9df4ea3ecd8bacbc146aabf5920d9
sha256sums = d6b4af56e0a80d3c813637bc0e9b74dae51f2fbd3919e992a342f9a5abd10acc
sha256sums = 763fd7e2804c5bcf2f78ed3fb3669528163f2ba0b0b4d14eda07174932761cc2
+ sha256sums = 8dfddabf8f231457327d4eb91a6d204af64f4c621038cdb488b050c07581a430
+ sha256sums = db68ebd99729865788da17d2b7d61e58602b0df494dcd83de58b5ad088dd225c
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index 456e808b8a13..fde5df7773a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ _enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
_reponame=syncthingtray
pkgname=syncthingtray
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
@@ -45,12 +45,16 @@ checkdepends=('cppunit' 'syncthing' 'iproute2' 'appstream')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
'https://github.com/Martchus/syncthingtray/commit/f121f5f740d799c2b29e9f5ce8e15ddae7857a28.patch'
- 'https://github.com/Martchus/syncthingtray/commit/ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch'
- 'https://github.com/Martchus/syncthingtray/commit/0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch')
+ 'https://github.com/Martchus/syncthingtray/commit/ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch'
+ 'https://github.com/Martchus/syncthingtray/commit/0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch'
+ 'https://github.com/Martchus/syncthingtray/commit/0ab21657c4feb0500299af79314664b05edfc365.patch'
+ 'https://github.com/Martchus/syncthingtray/commit/521567f2350baa1e75a60ad48f5ed7923777b024.patch')
sha256sums=('aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52'
'2df0516de56fa279af4fa1f85d524a1aa9e9df4ea3ecd8bacbc146aabf5920d9'
'd6b4af56e0a80d3c813637bc0e9b74dae51f2fbd3919e992a342f9a5abd10acc'
- '763fd7e2804c5bcf2f78ed3fb3669528163f2ba0b0b4d14eda07174932761cc2')
+ '763fd7e2804c5bcf2f78ed3fb3669528163f2ba0b0b4d14eda07174932761cc2'
+ '8dfddabf8f231457327d4eb91a6d204af64f4c621038cdb488b050c07581a430'
+ 'db68ebd99729865788da17d2b7d61e58602b0df494dcd83de58b5ad088dd225c')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
@@ -62,6 +66,8 @@ prepare() {
patch -p1 -i ../f121f5f740d799c2b29e9f5ce8e15ddae7857a28.patch
patch -p1 -i ../ad81c29a1d8024e79da51efc2b3dc19583be1e21.patch
patch -p1 -i ../0ca1fd163824e3100ff3ab258ffeb65a6ceadb3a.patch
+ patch -p1 -i ../0ab21657c4feb0500299af79314664b05edfc365.patch
+ patch -p1 -i ../521567f2350baa1e75a60ad48f5ed7923777b024.patch
}
build() {