summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2019-08-24 23:15:42 +0200
committerMartchus2019-08-24 23:15:42 +0200
commit6392f10dcfa9bf139487d7dbd1c5a7268feb3834 (patch)
tree1d0a31345ecf4c68aee456daf6e197c3d630de5b
parentad44d5ebd7cdf140f6a543b1ef159415f83622bf (diff)
downloadaur-6392f10dcfa9bf139487d7dbd1c5a7268feb3834.tar.gz
Update version
-rw-r--r--.SRCINFO5
-rw-r--r--.sync-conflict-20190519-131719-PKPUQWZ.SRCINFO33
-rw-r--r--PKGBUILD11
3 files changed, 43 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26cd6b4e79a6..0ca9ac9b2014 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
- pkgver = 0.9.1
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = i686
@@ -11,6 +11,7 @@ pkgbase = syncthingtray
license = GPL
checkdepends = cppunit
checkdepends = syncthing
+ checkdepends = iproute2
makedepends = cmake
makedepends = qt5-tools
makedepends = mesa
@@ -26,7 +27,7 @@ pkgbase = syncthingtray
depends = qt5-declarative
optdepends = kio: KIO plugin for Syncthing actions in Dolphin
optdepends = plasma-workspace: Plasmoid for Plasma 5 desktop
- source = syncthingtray-0.9.1.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.9.1.tar.gz
+ source = syncthingtray-0.10.0.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.10.0.tar.gz
sha256sums = 7db8661a16af117dd7ad494bb3264911a7dc926bcbdea887b4def396cf7e019e
pkgname = syncthingtray
diff --git a/.sync-conflict-20190519-131719-PKPUQWZ.SRCINFO b/.sync-conflict-20190519-131719-PKPUQWZ.SRCINFO
new file mode 100644
index 000000000000..deba119feeaf
--- /dev/null
+++ b/.sync-conflict-20190519-131719-PKPUQWZ.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = syncthingtray
+ pkgdesc = Tray application for Syncthing
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/Martchus/syncthingtray
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ checkdepends = cppunit
+ checkdepends = syncthing
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = mesa
+ makedepends = kio
+ makedepends = plasma-framework
+ makedepends = extra-cmake-modules
+ depends = qtutilities
+ depends = qt5-svg
+ depends = openssl
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = qt5-webengine
+ depends = qt5-declarative
+ optdepends = kio: KIO plugin for Syncthing actions in Dolphin
+ optdepends = plasma-workspace: Plasmoid for Plasma 5 desktop
+ source = syncthingtray-0.9.0.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.9.0.tar.gz
+ sha256sums = 48e6f18302e820ae599c3028db246cec553d1a3c33b20a021a471273c84b30e9
+
+pkgname = syncthingtray
+
diff --git a/PKGBUILD b/PKGBUILD
index b3e8f240296c..034527285274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ _enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=0.9.1
+pkgver=0.10.0
pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
@@ -38,7 +38,7 @@ depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
[[ $_enable_kio_plugin ]] && optdepends+=('kio: KIO plugin for Syncthing actions in Dolphin')
[[ $_enable_plasmoid ]] && optdepends+=('plasma-workspace: Plasmoid for Plasma 5 desktop')
makedepends=('cmake' 'qt5-tools' 'mesa')
-checkdepends=('cppunit' 'syncthing')
+checkdepends=('cppunit' 'syncthing' 'iproute2')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
@@ -51,12 +51,15 @@ ephemeral_port() {
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+
local additional_args=
[[ $_enable_kio_plugin ]] || additional_args+=' -DNO_FILE_ITEM_ACTION_PLUGIN=ON'
[[ $_enable_plasmoid ]] || additional_args+=' -DNO_PLASMOID=ON'
+
cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE:STRING='Release' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
-DJS_PROVIDER="${_js_provider}" \
-DSYSTEMD_SUPPORT=ON \