summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2019-01-07 20:13:40 +0100
committerMartchus2019-01-07 20:13:40 +0100
commit6daa2574ecbc2a598c28f4533e37e083688121e8 (patch)
tree88b6e0fe8af50276ae1bd1361262075ca2e51848
parentfba67cf39f59b2d89319ebc0714a0a436957d3d0 (diff)
downloadaur-6daa2574ecbc2a598c28f4533e37e083688121e8.tar.gz
Update version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7699653ae3c..56077e61d442 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
- pkgver = 0.8.3
+ pkgver = 0.8.4
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = i686
@@ -22,11 +22,12 @@ pkgbase = syncthingtray
depends = openssl
depends = desktop-file-utils
depends = xdg-utils
- depends = qt5-webkit
+ depends = qt5-webengine
+ depends = qt5-declarative
optdepends = kio: KIO plugin for Syncthing actions in Dolphin
optdepends = plasma-workspace: Plasmoid for Plasma 5 desktop
- source = syncthingtray-0.8.3.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.8.3.tar.gz
- sha256sums = 85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32
+ source = syncthingtray-0.8.4.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.8.4.tar.gz
+ sha256sums = 084289f3a295ef41ae4ebbc3976ca5782b47949ab73a7e12e33c72d271e869ea
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index b9de1de26829..1e29f8bc64a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# by setting SYNCTHING_TEST_TIMEOUT_FACTOR
# set the web view provider: either webkit, webengine, auto or none
-_webview_provider=${SYNCTHING_TRAY_WEBVIEW_PROVIDER:-webkit}
+_webview_provider=${SYNCTHING_TRAY_WEBVIEW_PROVIDER:-webengine}
# set the JavaScript provider: either script, qml, auto or none
_js_provider=${SYNCTHING_TRAY_JS_PROVIDER:-qml}
@@ -24,7 +24,7 @@ _enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=0.8.3
+pkgver=0.8.4
pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
@@ -33,6 +33,8 @@ depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
[[ $_webview_provider == none ]] && depends+=('qt5-base')
[[ $_webview_provider == webkit ]] && depends+=('qt5-webkit')
[[ $_webview_provider == webengine ]] && depends+=('qt5-webengine')
+[[ $_js_provider == script ]] && depends+=('qt5-script')
+[[ $_js_provider == qml ]] && depends+=('qt5-declarative')
[[ $_enable_kio_plugin ]] && optdepends+=('kio: KIO plugin for Syncthing actions in Dolphin')
[[ $_enable_plasmoid ]] && optdepends+=('plasma-workspace: Plasmoid for Plasma 5 desktop')
makedepends=('cmake' 'qt5-tools' 'mesa')
@@ -41,7 +43,7 @@ checkdepends=('cppunit' 'syncthing')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32')
+sha256sums=('084289f3a295ef41ae4ebbc3976ca5782b47949ab73a7e12e33c72d271e869ea')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1