summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-02-26 19:25:14 +0100
committerMartchus2017-02-26 19:25:14 +0100
commit98022f9d78b1264c8a6b82b33ac868285b117812 (patch)
tree49a3d2b30204cb8323e1861ee63428f35040cfa9
parent647a6b188036b791a288e580237a408dea2dde52 (diff)
downloadaur-98022f9d78b1264c8a6b82b33ac868285b117812.tar.gz
Update to 0.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f81a46f7b955..7c5a83c74221 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 1 16:41:11 UTC 2017
+# Sun Feb 26 18:25:14 UTC 2017
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
- pkgver = 0.4.1
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = i686
@@ -10,14 +10,16 @@ pkgbase = syncthingtray
license = GPL
makedepends = cmake
makedepends = qt5-tools
+ makedepends = kio
depends = qtutilities
depends = qt5-svg
depends = openssl
depends = desktop-file-utils
depends = xdg-utils
depends = qt5-webkit
- source = syncthingtray-0.4.1.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.4.1.tar.gz
- sha256sums = d7b14d80e64137c3adb5707dc61731c07aeffec805c7f0bd0960b54a41db6bc5
+ optdepends = kio: KIO plugin for Syncthing actions in Dolphin
+ source = syncthingtray-0.5.0.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.5.0.tar.gz
+ sha256sums = 8dfa07e224d691c3c58a5e354b9ed4bdfb8fc982fdbed47e07da3feb660f49cd
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index 78de6b870e87..1f9783ae40a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,13 @@
# set the web view provider: either webkit, webengine, auto or none
_webview_provider=webkit
+# set to non-empty string to enable KIO plugin to show Syncthing actions in
+# Dolphin file browser
+_enable_kio_plugin=1
+
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Tray application for Syncthing'
@@ -17,18 +21,23 @@ depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
[[ $_webview_provider == none ]] && depends+=('qt5-base')
[[ $_webview_provider == webkit ]] && depends+=('qt5-webkit')
[[ $_webview_provider == webengine ]] && depends+=('qt5-webengine')
+[[ $_enable_kio_plugin ]] && optdepends+=('kio: KIO plugin for Syncthing actions in Dolphin')
makedepends=('cmake' 'qt5-tools')
+[[ $_enable_kio_plugin ]] && makedepends+=('kio')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('d7b14d80e64137c3adb5707dc61731c07aeffec805c7f0bd0960b54a41db6bc5')
+sha256sums=('8dfa07e224d691c3c58a5e354b9ed4bdfb8fc982fdbed47e07da3feb660f49cd')
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ local additional_args=
+ [[ $_enable_kio_plugin ]] || additional_args+=NO_FILE_ITEM_ACTION_PLUGIN=ON
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
- -DSYSTEMD_SUPPORT=ON
+ -DSYSTEMD_SUPPORT=ON \
+ $additional_args
make
}