summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-11-08 20:48:14 +0100
committerMartchus2022-11-08 20:48:14 +0100
commit9d58a4969f35777e7a1ae095798f0971da12ddc6 (patch)
tree612b35e3311ff01d77805b97e428ababd61e8a5a
parentbb6aa75b3cf66ba30b295f3380c2fc8fef40a4a9 (diff)
downloadaur-9d58a4969f35777e7a1ae095798f0971da12ddc6.tar.gz
Avoid messing with user config when running tests
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991e8189409c..695288b0b9d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
pkgver = 1.3.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
@@ -41,6 +41,7 @@ pkgbase = syncthingtray
source = https://github.com/Martchus/syncthingtray/commit/521567f2350baa1e75a60ad48f5ed7923777b024.patch
source = https://github.com/Martchus/syncthingtray/commit/10ddc79382a385ac361a968121548e616d54004d.patch
source = https://github.com/Martchus/syncthingtray/commit/8f4961d1b93f1eb868d8782ba54b97d36721cb56.patch
+ source = https://github.com/Martchus/syncthingtray/commit/e5ffffcaec07c60b49ddc9bd1e8ffc19738f1ea2.patch
sha256sums = aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52
sha256sums = 2df0516de56fa279af4fa1f85d524a1aa9e9df4ea3ecd8bacbc146aabf5920d9
sha256sums = d6b4af56e0a80d3c813637bc0e9b74dae51f2fbd3919e992a342f9a5abd10acc
@@ -49,5 +50,6 @@ pkgbase = syncthingtray
sha256sums = db68ebd99729865788da17d2b7d61e58602b0df494dcd83de58b5ad088dd225c
sha256sums = 959d85df17243215fb144d4556e10dc2a3dc0a8e380ac5e2bc9e17de29f96027
sha256sums = 89c4ddda556926ea4dbb66d2c9373930804801fa276f8cbcb61daef2fe2e801e
+ sha256sums = 43dcb6baaa5ea16efecebc4bceb11677d04c82945a4ec0642483fe85f8909ba4
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index 6aef44f411b3..df5949d3fea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@ _enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
_reponame=syncthingtray
pkgname=syncthingtray
pkgver=1.3.0
-pkgrel=4
+pkgrel=5
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
@@ -50,7 +50,8 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/a
'https://github.com/Martchus/syncthingtray/commit/0ab21657c4feb0500299af79314664b05edfc365.patch'
'https://github.com/Martchus/syncthingtray/commit/521567f2350baa1e75a60ad48f5ed7923777b024.patch'
'https://github.com/Martchus/syncthingtray/commit/10ddc79382a385ac361a968121548e616d54004d.patch'
- 'https://github.com/Martchus/syncthingtray/commit/8f4961d1b93f1eb868d8782ba54b97d36721cb56.patch')
+ 'https://github.com/Martchus/syncthingtray/commit/8f4961d1b93f1eb868d8782ba54b97d36721cb56.patch'
+ 'https://github.com/Martchus/syncthingtray/commit/e5ffffcaec07c60b49ddc9bd1e8ffc19738f1ea2.patch')
sha256sums=('aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52'
'2df0516de56fa279af4fa1f85d524a1aa9e9df4ea3ecd8bacbc146aabf5920d9'
'd6b4af56e0a80d3c813637bc0e9b74dae51f2fbd3919e992a342f9a5abd10acc'
@@ -58,7 +59,8 @@ sha256sums=('aece0be140187a3c0c989a50007c3d5541d9e1abd51ec45b8c1e45ab783a9e52'
'8dfddabf8f231457327d4eb91a6d204af64f4c621038cdb488b050c07581a430'
'db68ebd99729865788da17d2b7d61e58602b0df494dcd83de58b5ad088dd225c'
'959d85df17243215fb144d4556e10dc2a3dc0a8e380ac5e2bc9e17de29f96027'
- '89c4ddda556926ea4dbb66d2c9373930804801fa276f8cbcb61daef2fe2e801e')
+ '89c4ddda556926ea4dbb66d2c9373930804801fa276f8cbcb61daef2fe2e801e'
+ '43dcb6baaa5ea16efecebc4bceb11677d04c82945a4ec0642483fe85f8909ba4')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
@@ -74,6 +76,7 @@ prepare() {
patch -p1 -i ../521567f2350baa1e75a60ad48f5ed7923777b024.patch
patch -p1 -i ../10ddc79382a385ac361a968121548e616d54004d.patch
patch -p1 -i ../8f4961d1b93f1eb868d8782ba54b97d36721cb56.patch
+ patch -p1 -i ../e5ffffcaec07c60b49ddc9bd1e8ffc19738f1ea2.patch
}
build() {