summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-03-22 17:10:10 +0100
committerMartchus2017-03-22 17:10:10 +0100
commita1c97cbdbbf0bb5d04712f1d24156655852bbde4 (patch)
treeaf53cd219c7ba5df55ca9b9b0bd3e8e3c30601e4
parent30254163b88a55381d25ad82c1b7f96ae4be682a (diff)
downloadaur-a1c97cbdbbf0bb5d04712f1d24156655852bbde4.tar.gz
Update to 0.5.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5bf6e5b614d..7a3572e0fad2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
# Generated by mksrcinfo v8
-# Sun Feb 26 20:18:52 UTC 2017
+# Wed Mar 22 16:10:10 UTC 2017
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
license = GPL
+ checkdepends = cppunit
+ checkdepends = syncthing
makedepends = cmake
makedepends = qt5-tools
makedepends = kio
@@ -18,7 +20,7 @@ pkgbase = syncthingtray
depends = xdg-utils
depends = qt5-webkit
optdepends = kio: KIO plugin for Syncthing actions in Dolphin
- source = syncthingtray-0.5.0.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.5.0.tar.gz
+ source = syncthingtray-0.5.1.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.5.1.tar.gz
sha256sums = 8dfa07e224d691c3c58a5e354b9ed4bdfb8fc982fdbed47e07da3feb660f49cd
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index d770a2d35036..cf7e49480066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _enable_kio_plugin=1
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Tray application for Syncthing'
@@ -23,6 +23,7 @@ depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
[[ $_webview_provider == webengine ]] && depends+=('qt5-webengine')
[[ $_enable_kio_plugin ]] && optdepends+=('kio: KIO plugin for Syncthing actions in Dolphin')
makedepends=('cmake' 'qt5-tools')
+checkdepends=('cppunit' 'syncthing')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
@@ -41,6 +42,11 @@ build() {
make
}
+check() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
+ make check
+}
+
package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
make DESTDIR="${pkgdir}" install