summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-07-06 23:13:10 +0200
committerMartchus2021-07-06 23:13:10 +0200
commitaf5cf5a7df01c4c4aadb9d6cb68d4cc5cdf0caaa (patch)
tree1a05c5ea1369a5c42189257c0ebbd19d13492f9e
parenta2f72568c42aeca43037e26c33855bae89e37848 (diff)
downloadaur-af5cf5a7df01c4c4aadb9d6cb68d4cc5cdf0caaa.tar.gz
Update version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f3f5cccb491..83ddf97d4d88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
- pkgver = 1.1.7
+ pkgver = 1.1.8
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = i686
@@ -16,11 +16,14 @@ pkgbase = syncthingtray
makedepends = ninja
makedepends = qt5-tools
makedepends = mesa
+ makedepends = boost
makedepends = kio
makedepends = plasma-framework
makedepends = extra-cmake-modules
depends = qtutilities
+ depends = boost-libs
depends = qt5-svg
+ depends = boost-libs
depends = openssl
depends = desktop-file-utils
depends = xdg-utils
@@ -28,7 +31,7 @@ pkgbase = syncthingtray
depends = qt5-declarative
optdepends = kio: KIO plugin for Syncthing actions in Dolphin
optdepends = plasma-workspace: Plasmoid for Plasma 5 desktop
- source = syncthingtray-1.1.7.tar.gz::https://github.com/Martchus/syncthingtray/archive/v1.1.7.tar.gz
- sha256sums = bd540efd58c3760db8953c230ab9558746700272da59dc9075a66b05b0a50c50
+ source = syncthingtray-1.1.8.tar.gz::https://github.com/Martchus/syncthingtray/archive/v1.1.8.tar.gz
+ sha256sums = 82a3ca453dd74bd2d73b49a5288eb52683ce26fbc7d4a2f6445aa57df6dc2f35
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index a058c0fe3e69..f9ad71938a4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,12 +24,12 @@ _enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=1.1.7
+pkgver=1.1.8
pkgrel=1
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
-depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
+depends=('qtutilities' 'boost-libs' 'qt5-svg' 'boost-libs' 'openssl' 'desktop-file-utils' 'xdg-utils')
[[ $_webview_provider == none ]] && depends+=('qt5-base')
[[ $_webview_provider == webkit ]] && depends+=('qt5-webkit')
[[ $_webview_provider == webengine ]] && depends+=('qt5-webengine')
@@ -37,13 +37,13 @@ depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
[[ $_js_provider == qml ]] && depends+=('qt5-declarative')
[[ $_enable_kio_plugin ]] && optdepends+=('kio: KIO plugin for Syncthing actions in Dolphin')
[[ $_enable_plasmoid ]] && optdepends+=('plasma-workspace: Plasmoid for Plasma 5 desktop')
-makedepends=('cmake' 'ninja' 'qt5-tools' 'mesa')
+makedepends=('cmake' 'ninja' 'qt5-tools' 'mesa' 'boost')
checkdepends=('cppunit' 'syncthing' 'iproute2')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('bd540efd58c3760db8953c230ab9558746700272da59dc9075a66b05b0a50c50')
+sha256sums=('82a3ca453dd74bd2d73b49a5288eb52683ce26fbc7d4a2f6445aa57df6dc2f35')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1