summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-11-04 17:01:58 +0100
committerMartchus2018-11-04 17:01:58 +0100
commitfba67cf39f59b2d89319ebc0714a0a436957d3d0 (patch)
treebfd1030430c4f5345dd93ed48cb1dfcb0d6757a1
parenta46cd588e53ac8b324558ffab8885c01ae0ea82a (diff)
downloadaur-fba67cf39f59b2d89319ebc0714a0a436957d3d0.tar.gz
Update version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a47b202dd72c..a7699653ae3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = syncthingtray
pkgdesc = Tray application for Syncthing
- pkgver = 0.8.2
+ pkgver = 0.8.3
pkgrel = 1
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL
checkdepends = cppunit
checkdepends = syncthing
@@ -22,8 +25,8 @@ pkgbase = syncthingtray
depends = qt5-webkit
optdepends = kio: KIO plugin for Syncthing actions in Dolphin
optdepends = plasma-workspace: Plasmoid for Plasma 5 desktop
- source = syncthingtray-0.8.2.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.8.2.tar.gz
- sha256sums = 34ebc32c78bfc2c6ebba390e78dafc32e6eddbac7e613ab3b4573f79cb1c01b2
+ source = syncthingtray-0.8.3.tar.gz::https://github.com/Martchus/syncthingtray/archive/v0.8.3.tar.gz
+ sha256sums = 85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32
pkgname = syncthingtray
diff --git a/PKGBUILD b/PKGBUILD
index af20a61ca81d..b9de1de26829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,26 @@
# by setting SYNCTHING_TEST_TIMEOUT_FACTOR
# set the web view provider: either webkit, webengine, auto or none
-_webview_provider=webkit
+_webview_provider=${SYNCTHING_TRAY_WEBVIEW_PROVIDER:-webkit}
+
+# set the JavaScript provider: either script, qml, auto or none
+_js_provider=${SYNCTHING_TRAY_JS_PROVIDER:-qml}
# set to non-empty string to enable KIO plugin to show Syncthing actions in
# Dolphin file browser
-_enable_kio_plugin=1
+_enable_kio_plugin=${SYNCTHING_TRAY_ENABLE_KIO_PLUGIN:-1}
# set to non-empty string to enable Plasmoid for Plasma 5 desktop
-_enable_plasmoid=1
+_enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
+
+[[ $_enable_kio_plugin == 0 ]] && _enable_kio_plugin=
+[[ $_enable_plasmoid == 0 ]] && _enable_plasmoid=
_reponame=syncthingtray
pkgname=syncthingtray
-pkgver=0.8.2
+pkgver=0.8.3
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing'
license=('GPL')
depends=('qtutilities' 'qt5-svg' 'openssl' 'desktop-file-utils' 'xdg-utils')
@@ -35,7 +41,7 @@ checkdepends=('cppunit' 'syncthing')
[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('34ebc32c78bfc2c6ebba390e78dafc32e6eddbac7e613ab3b4573f79cb1c01b2')
+sha256sums=('85c7578ce4b2d9c2454cfa4b5b3b5617829d1a77f579e7d33b34bd31542a8b32')
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
@@ -50,6 +56,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
+ -DJS_PROVIDER="${_js_provider}" \
-DSYSTEMD_SUPPORT=ON \
$additional_args
make