summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-02-28 13:15:18 +0100
committerMartchus2024-02-28 13:15:18 +0100
commit5fc579e164afc44162ed9f900bb03fe55f15c83a (patch)
tree1606286f54ec1d38d636961ceb6ce278d6c92e64
parent2e62454be7042c15f2794fb00ed808b301d2c1ee (diff)
downloadaur-5fc579e164afc44162ed9f900bb03fe55f15c83a.tar.gz
Enable KDE integrations by default
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b346a6731a96..2fac21e5efa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syncthingtray-qt6
pkgdesc = Tray application for Syncthing (using Qt 6)
pkgver = 1.4.13
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
@@ -18,6 +18,9 @@ pkgbase = syncthingtray-qt6
makedepends = qt6-declarative
makedepends = clang
makedepends = boost
+ makedepends = kio
+ makedepends = libplasma
+ makedepends = extra-cmake-modules
depends = libqtutilities-qt6.so
depends = libqtforkawesome-qt6.so
depends = libc++utilities.so
@@ -28,6 +31,8 @@ pkgbase = syncthingtray-qt6
depends = xdg-utils
depends = qt6-webengine
depends = qt6-declarative
+ optdepends = kio: KIO plugin for Syncthing actions in Dolphin
+ optdepends = plasma-workspace: Plasmoid for Plasma 6 desktop
source = syncthingtray-1.4.13.tar.gz::https://github.com/Martchus/syncthingtray/archive/v1.4.13.tar.gz
sha256sums = 18e604518fc252e49ce1cf8249f1ee15ac094c9d5303b02d23fe1d8468736cef
diff --git a/PKGBUILD b/PKGBUILD
index cce5327dc532..e4d09f4f0339 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,10 @@ _js_provider=${SYNCTHING_TRAY_JS_PROVIDER:-qml}
# set to non-empty string to enable KIO plugin to show Syncthing actions in
# Dolphin file browser
-_enable_kio_plugin=${SYNCTHING_TRAY_ENABLE_KIO_PLUGIN:-0}
+_enable_kio_plugin=${SYNCTHING_TRAY_ENABLE_KIO_PLUGIN:-1}
# set to non-empty string to enable Plasmoid for Plasma 5 desktop
-_enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-0}
+_enable_plasmoid=${SYNCTHING_TRAY_ENABLE_PLASMOID:-1}
[[ $_enable_kio_plugin == 0 ]] && _enable_kio_plugin=
[[ $_enable_plasmoid == 0 ]] && _enable_plasmoid=
@@ -27,7 +27,7 @@ _cfg=qt6
pkgname=syncthingtray-$_cfg
_name=${pkgname%-$_cfg}
pkgver=1.4.13
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing (using Qt 6)'
license=('GPL')