summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-11-30 20:02:52 +0100
committerMartchus2023-11-30 20:02:52 +0100
commit86c903ed3a870bc717fc78908e6a11497186f451 (patch)
tree4e0bc0ade39ed91d39fc511f22a2501cb250bece
parent0f9157cab230c44dfb00c66db1a210ff158da149 (diff)
downloadaur-86c903ed3a870bc717fc78908e6a11497186f451.tar.gz
Adapt to Plasma 6 beta
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch42
-rw-r--r--0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch29
-rw-r--r--PKGBUILD14
4 files changed, 85 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9c12b21e14b..fc748e117d0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syncthingtray-qt6
pkgdesc = Tray application for Syncthing (using Qt 6)
pkgver = 1.4.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Martchus/syncthingtray
arch = i686
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = syncthingtray-qt6
checkdepends = cppunit
checkdepends = syncthing
checkdepends = iproute2
- checkdepends = appstream
makedepends = cmake
makedepends = ninja
makedepends = qt6-tools
@@ -31,7 +30,11 @@ pkgbase = syncthingtray-qt6
depends = qt6-declarative
source = syncthingtray-1.4.9.tar.gz::https://github.com/Martchus/syncthingtray/archive/v1.4.9.tar.gz
source = 0001-Fix-install-path-of-KIO-plugin.patch
+ source = 0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
+ source = 0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch
sha256sums = f9003bbe185d355f9cac18862077fa2cc4e809f7f416d9b1dd5ef6474c926742
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = syncthingtray-qt6
diff --git a/0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch b/0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch
new file mode 100644
index 000000000000..ed8562471ec1
--- /dev/null
+++ b/0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch
@@ -0,0 +1,42 @@
+From ddbd6f309b3a353c9c40c71cd0877f6db6b680c6 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 30 Nov 2023 19:55:32 +0100
+Subject: [PATCH] Fix building Plasmoid after Plasma 6 beta release
+
+---
+ plasmoid/CMakeLists.txt | 2 +-
+ plasmoid/lib/CMakeLists.txt | 4 +++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/plasmoid/CMakeLists.txt b/plasmoid/CMakeLists.txt
+index e1eeaa4..18196ed 100644
+--- a/plasmoid/CMakeLists.txt
++++ b/plasmoid/CMakeLists.txt
+@@ -12,7 +12,7 @@ set(META_QT5_VERSION 5.8)
+ set(META_SRCDIR_REFS "${CMAKE_CURRENT_SOURCE_DIR}\n${CMAKE_CURRENT_SOURCE_DIR}/../syncthingconnector")
+
+ # find Plasma and its dependencies (which are not pulled-in automatically as of Plasma 6)
+-find_package(${KF_PACKAGE_PREFIX}Plasma REQUIRED)
++find_package(Plasma REQUIRED)
+ if (KF_MAJOR_VERSION GREATER_EQUAL 6)
+ find_package(${QT_PACKAGE_PREFIX}Qml REQUIRED)
+ find_package(${KF_PACKAGE_PREFIX}Config REQUIRED)
+diff --git a/plasmoid/lib/CMakeLists.txt b/plasmoid/lib/CMakeLists.txt
+index 1c6654a..a757cc4 100644
+--- a/plasmoid/lib/CMakeLists.txt
++++ b/plasmoid/lib/CMakeLists.txt
+@@ -40,8 +40,10 @@ list(APPEND ADDITIONAL_QT_MODULES Network Qml)
+ if (KF_MAJOR_VERSION GREATER_EQUAL 6)
+ set(Config_MODULE_TARGETS ${KF_PACKAGE_PREFIX}::ConfigCore)
+ list(APPEND ADDITIONAL_KF_MODULES Config)
++ use_package(TARGET_NAME Plasma::Plasma PACKAGE_NAME Plasma PACKAGE_ARGS REQUIRED)
++else ()
++ list(APPEND ADDITIONAL_KF_MODULES Plasma)
+ endif ()
+-list(APPEND ADDITIONAL_KF_MODULES Plasma)
+
+ include(BasicConfig)
+ include(QtGuiConfig)
+--
+2.43.0
+
diff --git a/0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch b/0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
new file mode 100644
index 000000000000..9fb0ce7702d8
--- /dev/null
+++ b/0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
@@ -0,0 +1,29 @@
+From eaf8d6d1647a55fea2f76185544799b891aa16a5 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 26 Nov 2023 17:06:06 +0100
+Subject: [PATCH] Mention PLASMA_ENABLE_QML_DEBUG in the Plasmoid testing docs
+
+This variable might be useful and now seems to be supported by
+`plasmawindowed`, see
+https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/3237.
+---
+ plasmoid/testing.md | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/plasmoid/testing.md b/plasmoid/testing.md
+index f80aa66..361e31d 100644
+--- a/plasmoid/testing.md
++++ b/plasmoid/testing.md
+@@ -48,6 +48,9 @@ It works quite well within a Plasma session when both shells are placed on diffe
+ edges.
+
+ ## Enable QML debugging
++It is not clear whether the following instructions are still valid for Plasma 6.
++It seems that QML debugging can be enabled under Plasma 6 by setting the environment variable
++`PLASMA_ENABLE_QML_DEBUG` but this has not been tested yet.
+
+ To enable QML debugging, it is required to rebuild `plasmoidviewer` with QML debugging
+ enabled.
+--
+2.43.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 4eba35ec67e9..6521250951ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ _cfg=qt6
pkgname=syncthingtray-$_cfg
_name=${pkgname%-$_cfg}
pkgver=1.4.9
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Tray application for Syncthing (using Qt 6)'
license=('GPL')
@@ -41,14 +41,16 @@ depends=('libqtutilities-qt6.so' 'libqtforkawesome-qt6.so' 'libc++utilities.so'
[[ $_enable_kio_plugin ]] && optdepends+=('kio: KIO plugin for Syncthing actions in Dolphin')
[[ $_enable_plasmoid ]] && optdepends+=('plasma-workspace: Plasmoid for Plasma 6 desktop')
makedepends=('cmake' 'ninja' 'qt6-tools' 'qt6-declarative' 'clang' 'boost')
-checkdepends=('cppunit' 'syncthing' 'iproute2' 'appstream')
+checkdepends=('cppunit' 'syncthing' 'iproute2')
[[ $_enable_kio_plugin ]] && makedepends+=('kio')
-[[ $_enable_plasmoid ]] && makedepends+=('plasma-framework' 'extra-cmake-modules')
+[[ $_enable_plasmoid ]] && makedepends+=('libplasma' 'extra-cmake-modules')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz"
- 0001-Fix-install-path-of-KIO-plugin.patch)
+ 0001-Fix-install-path-of-KIO-plugin.patch
+ 0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
+ 0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch)
sha256sums=('f9003bbe185d355f9cac18862077fa2cc4e809f7f416d9b1dd5ef6474c926742'
- SKIP)
+ SKIP SKIP SKIP)
ephemeral_port() {
comm -23 <(seq 49152 65535) <(ss -tan | awk '{print $4}' | cut -d':' -f2 | grep "[0-9]\{1,5\}" | sort | uniq) | shuf | head -n 1
@@ -57,6 +59,8 @@ ephemeral_port() {
prepare() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
patch -p1 -i ../0001-Fix-install-path-of-KIO-plugin.patch
+ patch -p1 -i ../0001-Mention-PLASMA_ENABLE_QML_DEBUG-in-the-Plasmoid-test.patch
+ patch -p1 -i ../0001-Fix-building-Plasmoid-after-Plasma-6-beta-release.patch
}
build() {