summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikos Toutountzoglou2023-09-14 07:49:10 +0200
committerNikos Toutountzoglou2023-09-14 07:49:10 +0200
commit24281ee4d5135a9992791ba891c512091ccb6de0 (patch)
treefd5d8265127cc0875207e55a789fde3a29a40309
parent299b7cfb156e6779c1d7544d5b1a3dd73e11c765 (diff)
downloadaur-24281ee4d5135a9992791ba891c512091ccb6de0.tar.gz
Fix for typo, see https://github.com/Samsung-Loki/Syndical/issues/11
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc7c4fa0d89d..92288aafdfda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syndical
pkgdesc = An alternative to SamLoader - cleaner code, easier to understand and tamper with.
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Samsung-Loki/Syndical
arch = any
license = MPL2
diff --git a/PKGBUILD b/PKGBUILD
index 83e0e3a8ba89..c1dbde070bc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=syndical
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
_pkgname="Syndical-${pkgver}"
_exe="Syndical.Application"
pkgdesc="An alternative to SamLoader - cleaner code, easier to understand and tamper with."
@@ -15,6 +15,13 @@ optdepends=('android-udev: Adds udev rules for non-root users (Group adbusers)')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Samsung-Loki/Syndical/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('0f43a8a6013169eed41cfe58b5b05c93d941e4afc47f693e0af8cd2a04350ece')
+prepare() {
+ cd "$srcdir"
+
+ # Fix for typo
+ sed -i "s|yelloe|yellow|" ${_pkgname}/${_exe}/Program.cs
+}
+
build() {
cd "$srcdir"