summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2021-02-11 00:43:02 -0500
committerKevin MacMartin2021-02-11 00:43:02 -0500
commit0fbeae0f98ae23eaa86c9e979f3c66d9cfbbdf14 (patch)
treebb04548399e2fb3fe08e490dff98ab9e5aea3a14
parent55c211e482585dfd152c3e0b18b68d9bd799d45a (diff)
downloadaur-0fbeae0f98ae23eaa86c9e979f3c66d9cfbbdf14.tar.gz
Update to 20210210.r3836.d072b5064, sync deps with the non-git package, include tests, and sync contributors with the non-git package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c7159b4550c..026bd97c3766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = synergy-git
pkgdesc = Share a single mouse and keyboard between multiple computers
- pkgver = 20201231.r3789.ede272185
+ pkgver = 20210210.r3836.d072b5064
pkgrel = 1
url = http://synergy-foss.org
arch = i686
@@ -10,17 +10,19 @@ pkgbase = synergy-git
arch = armv7h
arch = aarch64
license = GPL2
- makedepends = cmake
- makedepends = git
makedepends = libxt
- makedepends = qt5-tools
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = gmock
+ makedepends = gtest
+ depends = gcc-libs
+ depends = libxtst
+ depends = libxinerama
+ depends = libxkbcommon-x11
depends = avahi
depends = curl
- depends = libxinerama
- depends = libxrandr
- depends = libxtst
- depends = qt5-base
- optdepends = openssl: encryption support
+ depends = openssl
+ optdepends = qt5-base: gui support
provides = synergy
conflicts = synergy
source = synergy::git+https://github.com/symless/synergy-core.git
diff --git a/PKGBUILD b/PKGBUILD
index 62e8acfb111f..93b7b9ba640e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Kevin MacMartin <prurigro@gmail.com>
-# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Jelle van der Waa <jelle vdwaa nl>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: Dale Blount <dale@archlinux.org>
# Contributor: Michael Düll <mail@akurei.me>
+# Contributor: Luca Corbatto <lucaatcorbatto.de>
# Ported from the upstream synergy package
_pkgname=synergy
pkgname=$_pkgname-git
-pkgver=20201231.r3789.ede272185
+pkgver=20210210.r3836.d072b5064
pkgrel=1
pkgdesc='Share a single mouse and keyboard between multiple computers'
url='http://synergy-foss.org'
@@ -17,9 +18,9 @@ arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('GPL2')
provides=("$_pkgname")
conflicts=("$_pkgname")
-depends=('avahi' 'curl' 'libxinerama' 'libxrandr' 'libxtst' 'qt5-base')
-makedepends=('cmake' 'git' 'libxt' 'qt5-tools')
-optdepends=('openssl: encryption support')
+depends=('gcc-libs' 'libxtst' 'libxinerama' 'libxkbcommon-x11' 'avahi' 'curl' 'openssl')
+makedepends=('libxt' 'cmake' 'qt5-base' 'gmock' 'gtest')
+optdepends=('qt5-base: gui support')
source=(
"$_pkgname::git+https://github.com/symless/$_pkgname-core.git"
@@ -45,12 +46,19 @@ pkgver() {
}
build() {
- # Build Synergy
+ # Build synergy
cd $_pkgname
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}
+check() {
+ # Run tests
+ cd $_pkgname
+ ./bin/unittests
+ ./bin/integtests
+}
+
package() {
# Install systemd service and socket
install -Dm644 ${_pkgname}s_at.service "$pkgdir/usr/lib/systemd/system/${_pkgname}s@.service"