summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-07-07 15:20:45 -0400
committerKevin MacMartin2015-07-07 15:20:45 -0400
commitef6ed4b3612c34c32ab28d513ffc7e0f3faca519 (patch)
treeb86185a3e8931ecef7785493f10637f86c56afcd
downloadaur-ef6ed4b3612c34c32ab28d513ffc7e0f3faca519.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD93
-rw-r--r--synergys_at.service11
-rw-r--r--synergys_at.socket9
5 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcdadf09164e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = synergy-git
+ pkgdesc = Share a single mouse and keyboard between multiple computers
+ pkgver = 20150706.r2251.cfec3a9
+ pkgrel = 1
+ url = http://synergy-foss.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = libxt
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = unzip
+ depends = gcc-libs
+ depends = libxtst
+ depends = libxinerama
+ depends = libxkbcommon-x11
+ depends = avahi
+ depends = curl
+ optdepends = qt5-base: gui support
+ optdepends = openssl: encryption support
+ provides = synergy
+ conflicts = synergy
+ source = synergy::git+https://github.com/synergy/synergy.git
+ source = synergys_at.socket
+ source = synergys_at.service
+ sha1sums = SKIP
+ sha1sums = 7ec33221725fc496b807e0f435c5e87b590beb5d
+ sha1sums = 65ab58cc3546d6374a05a6a260f15045632e43ce
+
+pkgname = synergy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..59bb23dfc534
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+synergy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d8cff554326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Jelle van der Waa <jelle vdwaa nl>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Dale Blount <dale@archlinux.org>
+# Contributor: Michael Düll <mail@akurei.me>
+# Ported from the upstream synergy package
+
+_pkgname=synergy
+pkgname=$_pkgname-git
+pkgver=20150706.r2251.cfec3a9
+pkgrel=1
+pkgdesc='Share a single mouse and keyboard between multiple computers'
+url='http://synergy-foss.org'
+arch=('i686' 'x86_64')
+depends=('gcc-libs' 'libxtst' 'libxinerama' 'libxkbcommon-x11' 'avahi' 'curl')
+makedepends=('libxt' 'cmake' 'qt5-base' 'unzip')
+optdepends=(
+ 'qt5-base: gui support'
+ 'openssl: encryption support'
+)
+license=('GPL2')
+source=(
+ "$_pkgname::git+https://github.com/$_pkgname/$_pkgname.git"
+ "${_pkgname}s_at.socket"
+ "${_pkgname}s_at.service"
+)
+sha1sums=(
+ 'SKIP'
+ '7ec33221725fc496b807e0f435c5e87b590beb5d'
+ '65ab58cc3546d6374a05a6a260f15045632e43ce'
+)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" \
+ "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname/ext
+ unzip gmock-1.6.0.zip -d gmock-1.6.0
+ unzip gtest-1.6.0.zip -d gtest-1.6.0
+}
+
+build() {
+ cd $_pkgname
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+
+ cd src/gui
+ qmake
+ make
+}
+
+package() {
+ # install systemd service and socket
+ install -Dm644 ${_pkgname}s_at.service "$pkgdir/usr/lib/systemd/system/${_pkgname}s@.service"
+ install -Dm644 ${_pkgname}s_at.socket "$pkgdir/usr/lib/systemd/system/${_pkgname}s@.socket"
+
+ cd $_pkgname
+
+ # install binary
+ install -Dm755 bin/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 bin/${_pkgname}c "$pkgdir/usr/bin/${_pkgname}c"
+ install -Dm755 bin/${_pkgname}d "$pkgdir/usr/bin/${_pkgname}d"
+ install -Dm755 bin/${_pkgname}s "$pkgdir/usr/bin/${_pkgname}s"
+ install -Dm755 bin/syntool "$pkgdir/usr/bin/syntool"
+ install -Dm755 bin/u$_pkgname "$pkgdir/usr/bin/u$_pkgname"
+
+ # install config
+ install -Dm644 doc/$_pkgname.conf.example "$pkgdir/etc/$_pkgname.conf.example"
+ install -Dm644 doc/$_pkgname.conf.example-advanced "$pkgdir/etc/$_pkgname.conf.example-advanced"
+ install -Dm644 doc/$_pkgname.conf.example-basic "$pkgdir/etc/$_pkgname.conf.example-basic"
+
+ # install manfiles
+ install -Dm644 doc/${_pkgname}c.man "$pkgdir/usr/share/man/man1/${_pkgname}c.1"
+ install -Dm644 doc/${_pkgname}s.man "$pkgdir/usr/share/man/man1/${_pkgname}s.1"
+
+ # plugin
+ install -Dm644 bin/plugins/libns.so "$pkgdir/usr/lib/$_pkgname/libns.so"
+
+ # install desktop/icon stuff
+ install -Dm644 res/$_pkgname.ico "$pkgdir/usr/share/icons/$_pkgname.ico"
+ install -Dm644 res/$_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
+
diff --git a/synergys_at.service b/synergys_at.service
new file mode 100644
index 000000000000..813fd6bd2c0e
--- /dev/null
+++ b/synergys_at.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Synergy Server Daemon
+After=network.target
+
+[Service]
+User=%i
+ExecStart=/usr/bin/synergys --no-daemon --config /etc/synergy.conf
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/synergys_at.socket b/synergys_at.socket
new file mode 100644
index 000000000000..9ab4bca7d852
--- /dev/null
+++ b/synergys_at.socket
@@ -0,0 +1,9 @@
+[Unit]
+Conflicts=synergys@.service
+
+[Socket]
+ListenStream=24800
+Accept=false
+
+[Install]
+WantedBy=sockets.target