summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2022-09-16 20:15:55 -0700
committerxiota2022-09-16 20:17:00 -0700
commit9d98fb67f0e672bcb80e0e1b95655f4bfa81cfee (patch)
tree81d578e358ab5d904180e2f42caa5fccc85c131d
parent57b8211b203299ecb32fdfb2a2c3732f2c6e4414 (diff)
downloadaur-9d98fb67f0e672bcb80e0e1b95655f4bfa81cfee.tar.gz
Revert to 1.14.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1378d90e66a1..1468480a0511 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = synergy1-bin
pkgdesc = Keyboard and mouse sharing solution. Synergy allows you to share one mouse and keyboard between multiple computers. Work seamlessly across Windows, macOS and Linux.
- pkgver = 1.14.5.17
+ pkgver = 1.14.5
pkgrel = 1
- url = https://github.com/DEAKSoftware/Synergy-Binaries
+ url = https://symless.com/synergy
install = synergy1-bin.install
arch = x86_64
license = unknown
@@ -19,7 +19,7 @@ pkgbase = synergy1-bin
conflicts = synergy
options = !strip
options = !emptydirs
- source = https://github.com/DEAKSoftware/Synergy-Binaries/releases/download/1.14.5.17/synergy-1.14.5.17-ad30acbc-ubuntu-22.04-jammy-jellyfish-x86_64.deb
- sha256sums = bd0125f91b3f5a3e2953d33478716a3b39641c50cb6db76bd15ed4f452263d77
+ source = https://binaries.symless.com/synergy/v1-core-standard/1.14.5-stable.a975f61a/synergy_1.14.5-stable.a975f61a_ubuntu20_amd64.deb
+ sha256sums = f4937d7235f8bb9cd7c8fc95ce5f132d75f3304268af2578d58b7aa8afd5dbc0
pkgname = synergy1-bin
diff --git a/PKGBUILD b/PKGBUILD
index c35365e2d263..be23aa723382 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Contributor: Catriel Müller <catriel at gmail dot com>
+_dlhash=a975f61a
pkgname=synergy1-bin
-pkgver=1.14.5.17
+pkgver=1.14.5
pkgrel=1
pkgdesc="Keyboard and mouse sharing solution. Synergy allows you to share one mouse and keyboard between multiple computers. Work seamlessly across Windows, macOS and Linux."
arch=('x86_64')
-url="https://github.com/DEAKSoftware/Synergy-Binaries"
+url="https://symless.com/synergy"
license=('unknown')
depends=(
'avahi>=0.6.16'
@@ -23,14 +24,15 @@ options=('!strip' '!emptydirs')
install=${pkgname}.install
source=(
- "https://github.com/DEAKSoftware/Synergy-Binaries/releases/download/1.14.5.17/synergy-1.14.5.17-ad30acbc-ubuntu-22.04-jammy-jellyfish-x86_64.deb"
+ "https://binaries.symless.com/synergy/v1-core-standard/${pkgver}-stable.${_dlhash}/synergy_${pkgver}-stable.${_dlhash}_ubuntu20_amd64.deb"
)
+
sha256sums=(
- 'bd0125f91b3f5a3e2953d33478716a3b39641c50cb6db76bd15ed4f452263d77'
+ 'f4937d7235f8bb9cd7c8fc95ce5f132d75f3304268af2578d58b7aa8afd5dbc0'
)
package() {
# Extract package data
- tar xf data.tar.zst -C "${pkgdir}"
+ tar xf data.tar.xz -C "${pkgdir}"
install -D -m644 "${pkgdir}/usr/share/doc/synergy/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}