summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCatriel Müller2021-01-02 19:41:39 -0300
committerCatriel Müller2021-01-02 19:41:39 -0300
commitf2817481b559a79aabb85c38ab225f939bfb8096 (patch)
treeaad2e6f3f9a2590e16e1417241728f69dfd05021
downloadaur-f2817481b559a79aabb85c38ab225f939bfb8096.tar.gz
Initial Version
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD21
-rw-r--r--synergy1-bin.install13
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff7366cf2a86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = synergy1-bin
+ pkgdesc = Keyboard and mouse sharing solution. Synergy allows you to share one mouse and keyboard between multiple computers. Work seamlessly across Windows, macOS and Linux.
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = https://symless.com/synergy
+ install = synergy1-bin.install
+ arch = x86_64
+ groups =
+ license = unknown
+ depends = avahi>=0.6.16
+ depends = gcc-libs>=5.2
+ depends = glibc>=2.14
+ depends = hicolor-icon-theme
+ depends = libx11>=1.2.99.901
+ depends = libxext
+ depends = libxi>=1.2.99.4
+ depends = libxtst
+ depends = openssl>=1.1.0
+ depends = qt5-base>=5.12.2
+ conflicts = synergy
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://binaries.symless.com/synergy/v1-core-standard/1.13.0-stable-bdb8f767/synergy_1.13.0-stable.bdb8f767_ubuntu20_amd64.deb
+ sha512sums_x86_64 = d259272548db370a948bb3d97a1c4b2469eebbbb1aa079896bcf25ebe26ecd25331ada7e6d58fde125599a436e8d28c9a9e62cbfa834260cf1ccb9f6a76c23b6
+
+pkgname = synergy1-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0069723bd8fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Catriel Müller <catriel at gmail dot com>
+pkgname=synergy1-bin
+pkgver=1.13.0
+pkgrel=1
+pkgdesc="Keyboard and mouse sharing solution. Synergy allows you to share one mouse and keyboard between multiple computers. Work seamlessly across Windows, macOS and Linux."
+arch=('x86_64')
+url="https://symless.com/synergy"
+license=('unknown')
+groups=('')
+depends=('avahi>=0.6.16' 'gcc-libs>=5.2' 'glibc>=2.14' 'hicolor-icon-theme' 'libx11>=1.2.99.901' 'libxext' 'libxi>=1.2.99.4' 'libxtst' 'openssl>=1.1.0' 'qt5-base>=5.12.2')
+conflicts=('synergy')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://binaries.symless.com/synergy/v1-core-standard/1.13.0-stable-bdb8f767/synergy_1.13.0-stable.bdb8f767_ubuntu20_amd64.deb")
+sha512sums_x86_64=('d259272548db370a948bb3d97a1c4b2469eebbbb1aa079896bcf25ebe26ecd25331ada7e6d58fde125599a436e8d28c9a9e62cbfa834260cf1ccb9f6a76c23b6')
+
+package(){
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+ install -D -m644 "${pkgdir}/usr/share/doc/synergy/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/synergy1-bin.install b/synergy1-bin.install
new file mode 100644
index 000000000000..a3ff5b674f7e
--- /dev/null
+++ b/synergy1-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}