summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sager2019-12-08 18:07:43 -0800
committerMike Sager2019-12-08 18:07:43 -0800
commitd82905d951b351d32ef93a4d4e5659d9769a4fa1 (patch)
tree2fa52f1b671467bb98d4cafabe89afd6d86e6cc7
downloadaur-d82905d951b351d32ef93a4d4e5659d9769a4fa1.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
-rw-r--r--synfigstudio.desktop7
-rw-r--r--synfigstudio.pngbin0 -> 19553 bytes
-rw-r--r--synfigstudio.sh2
6 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0adf130d8611
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = synfigstudio-appimage
+ pkgdesc = Professional vector animation program (GUI)
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://www.synfig.org
+ arch = x86_64
+ license = GPL3
+ depends = hicolor-icon-theme
+ provides = synfigstudio
+ conflicts = synfigstudio
+ options = !strip
+ source = https://github.com/synfig/synfig/releases/download/v1.2.2/SynfigStudio-1.2.2-18.09.14-linux64-286f1.appimage
+ source = synfigstudio.desktop
+ source = synfigstudio.png
+ source = synfigstudio.sh
+ sha256sums = 6c4cb9ce465aa1e1bd8fd528add089cd1bdf690847f61cceb428a8f72e5e02f9
+ sha256sums = cf1d7721325196f0b606a152c7b651c0abf735cb9c72ffbdb036e30517d3f725
+ sha256sums = 3e6b8fd52343b942c131f51f791e6ec8bcce36a15e4538b859f01a2f5674958e
+ sha256sums = 17142491c74d26b8fad361f946f4d599e35991625ec6b966b88be11665816930
+
+pkgname = synfigstudio-appimage
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..374f665f3875
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.appimage
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f0ae734e719
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Mike Sager <mike at mikesager dot name>
+
+_pkgname=synfigstudio
+pkgname=${_pkgname}-appimage
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Professional vector animation program (GUI)"
+arch=('x86_64')
+url="https://www.synfig.org"
+license=('GPL3')
+provides=('synfigstudio')
+conflicts=('synfigstudio')
+depends=('hicolor-icon-theme')
+#depends=('gtkmm3' 'synfig' 'sdl_image')
+#makedepends=('openexr' 'libmagick6' 'xorg-fonts-100dpi' 'xorg-fonts-75dpi'
+# 'xorg-fonts-misc' 'xorg-fonts-type1' 'intltool' 'imagemagick')
+
+_appimagedistrover=18.09.14
+_appimagearch=linux64
+_appimagecommitsuffix=286f1
+
+source=(
+ "https://github.com/synfig/synfig/releases/download/v${pkgver}/SynfigStudio-${pkgver}-${_appimagedistrover}-${_appimagearch}-${_appimagecommitsuffix}.appimage"
+ "synfigstudio.desktop"
+ "synfigstudio.png"
+ "synfigstudio.sh"
+ )
+sha256sums=(
+ '6c4cb9ce465aa1e1bd8fd528add089cd1bdf690847f61cceb428a8f72e5e02f9'
+ 'cf1d7721325196f0b606a152c7b651c0abf735cb9c72ffbdb036e30517d3f725'
+ '3e6b8fd52343b942c131f51f791e6ec8bcce36a15e4538b859f01a2f5674958e'
+ '17142491c74d26b8fad361f946f4d599e35991625ec6b966b88be11665816930'
+ )
+
+options=(!strip)
+_filename=./SynfigStudio-${pkgver}-${_appimagedistrover}-${_appimagearch}-${_appimagecommitsuffix}.appimage
+
+package() {
+ cd "$srcdir"
+ install -Dm755 "${_filename}" "${pkgdir}/opt/appimages/${_pkgname}.AppImage"
+ install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${_pkgname}.png"
+}
diff --git a/synfigstudio.desktop b/synfigstudio.desktop
new file mode 100644
index 000000000000..dfd630d5c208
--- /dev/null
+++ b/synfigstudio.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Synfig Studio
+Exec=synfigstudio
+Icon=synfigstudio
+Categories=Graphics;
+MimeType=application/x-sif;
diff --git a/synfigstudio.png b/synfigstudio.png
new file mode 100644
index 000000000000..3f09db59d5b2
--- /dev/null
+++ b/synfigstudio.png
Binary files differ
diff --git a/synfigstudio.sh b/synfigstudio.sh
new file mode 100644
index 000000000000..c492e8fb37f3
--- /dev/null
+++ b/synfigstudio.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/appimages/synfigstudio.appimage "$@"