aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Weisgerber2018-07-02 12:52:54 +0200
committerSebastian Weisgerber2018-07-02 12:52:54 +0200
commit3d170a4c6aad57fc90c81544088b0ab35e51e97d (patch)
treecac4a701f6fde55f8e1e4dae66038a4fd5e4109f
parent696c93091179412691aedc6bfcbe9f62d459de9c (diff)
downloadaur-3d170a4c6aad57fc90c81544088b0ab35e51e97d.tar.gz
Updated to 2.1.2-241
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
-rw-r--r--README.md17
4 files changed, 30 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4875732eda54..55e7ca63ae9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = synology-note-station
pkgdesc = Note Station for desktop connects you with Note Station on your Synology NAS. You can manage all the notes/to-do list offline, right from your local computer.
- pkgver = 2.0.225
- pkgrel = 2
+ pkgver = 2.1.2_241
+ pkgrel = 1
url = https://www.synology.com/support/download/
arch = i686
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = synology-note-station
depends = libxss
depends = nss
options = emptydirs
- source = https://global.download.synology.com/download/Tools/NoteStationClient/2.0.225/Fedora/x86_64/synology-note-station-2.0.225-linux-x86_64.rpm
- md5sums = e9eee6e055f11c5ec301f12c3fe1e560
+ source = https://global.download.synology.com/download/Tools/NoteStationClient/2.1.2-241/Fedora/x86_64/synology-note-station-2.1.2-241-linux-x86_64.rpm
+ md5sums = 9abb955ab7ab2b31685e59a1fd5a3094
pkgname = synology-note-station
diff --git a/.gitignore b/.gitignore
index 240af40bd9a4..ff78cbcddabb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
synology-note-station-*
src/
pkg/
+.idea/
diff --git a/PKGBUILD b/PKGBUILD
index 004ffb9f0758..87f596bca46d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastian Weisgerber <sweisgerber.dev@gmail.com>
pkgname=synology-note-station
-pkgver=2.0.225
-pkgrel=2
+pkgver=2.1.2_241
+pkgrel=1
pkgdesc="Note Station for desktop connects you with Note Station on your Synology NAS. You can manage all the notes/to-do list offline, right from your local computer."
arch=('i686' 'x86_64')
url="https://www.synology.com/support/download/"
@@ -10,12 +10,12 @@ depends=('gconf' 'gtk3' 'libxss' 'nss')
makedepends=('rpmextract')
options=('emptydirs')
-if [[ "$CARCH" == "i686" ]]; then
- source=("https://global.download.synology.com/download/Tools/NoteStationClient/2.0.225/Fedora/i686/synology-note-station-2.0.225-linux-i386.rpm")
- md5sums=('27b34e73582e90f4eb5ae5a634a29440')
-elif [[ "$CARCH" == "x86_64" ]]; then
- source=("https://global.download.synology.com/download/Tools/NoteStationClient/2.0.225/Fedora/x86_64/synology-note-station-2.0.225-linux-x86_64.rpm")
- md5sums=('e9eee6e055f11c5ec301f12c3fe1e560')
+if [[ ${CARCH} == "i686" ]]; then
+ source=("https://global.download.synology.com/download/Tools/NoteStationClient/2.1.2-241/Fedora/i686/synology-note-station-2.1.2-241-linux-i386.rpm")
+ md5sums=('7ff0757a3562ab94a07a3c44c34f6022')
+elif [[ ${CARCH} == "x86_64" ]]; then
+ source=("https://global.download.synology.com/download/Tools/NoteStationClient/2.1.2-241/Fedora/x86_64/synology-note-station-2.1.2-241-linux-x86_64.rpm")
+ md5sums=('9abb955ab7ab2b31685e59a1fd5a3094')
fi
package() {
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..ce46e701027a
--- /dev/null
+++ b/README.md
@@ -0,0 +1,17 @@
+
+
+## Build
+
+```bash
+# Test PKGBUILD
+namcap PKGBUILD
+# Build
+makepkg
+# Test artifact
+namcap <package file name>.pkg.tar.xz
+# Install
+pacman -U <package file name>.pkg.tar.xz
+# Generate SRCINFO
+makepkg --printsrcinfo > .SRCINFO
+# Commit & Publish
+```