aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Weisgerber2017-10-10 12:05:42 +0200
committerSebastian Weisgerber2017-10-10 12:05:42 +0200
commitf55c736c7a67abc1aba84140014d355d03557f20 (patch)
tree86f89399525680346bdf0b60626a77c2c340219f
downloadaur-f55c736c7a67abc1aba84140014d355d03557f20.tar.gz
Initial commit with a working PKGBUILD of synologys new notestation desktop client
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdf14701ba00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = synology-note-station
+ pkgdesc = Note Station for desktop connects you with Note Station on your Synology NAS. You can manage all the notes/to-do list offline, right from your local computer.
+ pkgver = 2.0.220
+ pkgrel = 1
+ url = https://www.synology.com/support/download/
+ arch = x86_64
+ license = (C) Synology: Proprietary
+ makedepends = rpmextract
+ options = emptydirs
+ source = https://global.download.synology.com/download/Tools/NoteStationClient/2.0.220/Fedora/x86_64/synology-note-station-2.0.220-linux-x86_64.rpm
+ md5sums = 7fb9ddfb7b9d3bfc4190a36b3ab73a97
+
+pkgname = synology-note-station
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..987b49cc2937
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+ # Maintainer: Sebastian Weisgerber <sweisgerber.dev@gmail.com>
+pkgname=synology-note-station
+pkgver=2.0.220
+pkgrel=1
+pkgdesc="Note Station for desktop connects you with Note Station on your Synology NAS. You can manage all the notes/to-do list offline, right from your local computer."
+arch=('x86_64')
+url="https://www.synology.com/support/download/"
+license=('(C) Synology: Proprietary')
+depends=('')
+makedepends=('rpmextract')
+options=('emptydirs')
+source=("https://global.download.synology.com/download/Tools/NoteStationClient/2.0.220/Fedora/x86_64/synology-note-station-2.0.220-linux-x86_64.rpm")
+md5sums=('7fb9ddfb7b9d3bfc4190a36b3ab73a97')
+
+build() {
+ rpmextract.sh synology-note-station-2.0.220-linux-x86_64.rpm
+}
+
+package() {
+ rsync -ruDq $srcdir/opt $pkgdir/
+ rsync -ruDq $srcdir/usr $pkgdir/
+}