summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPival812016-07-04 16:34:15 +0200
committerPival812016-07-04 16:34:15 +0200
commit88b46cb9dbac13f7caf9aec94667ad0865fc7ca6 (patch)
tree95167186ede83ba0195feafa959740b897f0ffc8
downloadaur-88b46cb9dbac13f7caf9aec94667ad0865fc7ca6.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--syntaxhighlighting.install4
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c5840761725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jul 4 14:33:57 UTC 2016
+pkgbase = syntaxhighlighting
+ pkgdesc = C# API SyntaxHighlighting, to color text,html, xml and spec.
+ pkgver = 1.0.1.3
+ pkgrel = 1
+ url = monoosc.sourceforge.net
+ install = syntaxhighlighting.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = mono
+ makedepends = pulseaudio
+ source_x86_64 = http://download.opensuse.org/repositories/home:/surfzoid/Fedora_20/x86_64/SyntaxHighlighting-1.0.1.3-57.3.x86_64.rpm
+ md5sums_x86_64 = 3732f40fc9554555a6093b8f984c5104
+
+pkgname = syntaxhighlighting
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dfa26cc8e2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Valerio Pizzi (Pival81) <pival81@yahoo.com>
+
+pkgname="syntaxhighlighting"
+pkgver=1.0.1.3
+pkgrel=1
+pkgdesc="C# API SyntaxHighlighting, to color text,html, xml and spec."
+url="monoosc.sourceforge.net"
+makedepends=('mono' 'pulseaudio')
+arch=('i686' 'x86_64')
+license=('GPL3')
+install=syntaxhighlighting.install
+source_x86_64=("http://download.opensuse.org/repositories/home:/surfzoid/Fedora_20/x86_64/SyntaxHighlighting-1.0.1.3-57.3.x86_64.rpm")
+source_i386=("http://download.opensuse.org/repositories/home:/surfzoid/Fedora_20/i686/SyntaxHighlighting-1.0.1.3-57.3.i686.rpm")
+md5sums_x86_64=("3732f40fc9554555a6093b8f984c5104")
+md5sum_i386=("361f87918ca0e493fade282f6af5be58")
+if test "$CARCH" == x86_64; then
+ _arch_=x86_64
+else
+ _arch_=i686
+fi
+
+package() {
+ cd $pkgdir
+ rpmextract.sh $srcdir/SyntaxHighlighting-1.0.1.3-57.3.$_arch_.rpm
+}
diff --git a/syntaxhighlighting.install b/syntaxhighlighting.install
new file mode 100644
index 000000000000..37f71ffb514e
--- /dev/null
+++ b/syntaxhighlighting.install
@@ -0,0 +1,4 @@
+post_install() {
+ gacutil -i /usr/lib/syntaxhighlighting/SyntaxHighlighting.dll
+}
+