summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndres Gongora2020-04-12 12:12:33 +0200
committerAndres Gongora2020-04-12 12:12:33 +0200
commit3b391b7f4867eaea27e1080374ee111de56b3c7c (patch)
tree76b64f049054e1359633c3f893d4458e58d787d2
downloadaur-3b391b7f4867eaea27e1080374ee111de56b3c7c.tar.gz
Initial commit
Signed-off-by: Andres Gongora <mail@andresgongora.com>
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD45
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3459d69edb02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = synth-shell-greeter-git
+ pkgdesc = Terminal greeter to overwiew system health and status
+ pkgver = v1.0.r0.gbafabea
+ pkgrel = 1
+ url = https://github.com/andresgongora/synth-shell-greeter
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = sed
+ makedepends = grep
+ depends = bash
+ depends = bc
+ depends = ldns
+ depends = lm_sensors
+ optdepends =
+ provides = synth-shell-greeter
+ conflicts = synth-shell-greeter
+ source = git://github.com/andresgongora/synth-shell-greeter.git#branch=master
+ md5sums = SKIP
+
+pkgname = synth-shell-greeter-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..614254359c5d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+## INGORE ALL
+**
+
+## EXCEPTIONS
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cbba21cdbaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Andres Gongora <mail at andresgongora dot com>
+
+pkgname="synth-shell-greeter-git"
+pkgver=v1.0.r0.gbafabea
+pkgrel=1
+_branch=master
+pkgdesc="Terminal greeter to overwiew system health and status"
+arch=('any')
+url="https://github.com/andresgongora/synth-shell-greeter"
+license=('GPL3')
+depends=('bash' 'bc' 'ldns' 'lm_sensors')
+makedepends=('git' 'sed' 'grep')
+optdepends=("")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git://github.com/andresgongora/${pkgname%-git}.git#branch=$_branch")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule update --init --recursive
+}
+
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ chmod +x ./setup.sh
+ rm -rf build
+ ./setup.sh "build/${pkgname%-git}.sh" "build/config/"
+}
+
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D -m755 "./build/${pkgname%-git}.sh" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -d "$pkgdir/etc/synth-shell/"
+ (cd "build/config" && find -type f -exec install -Dm 644 "{}" "$pkgdir/etc/synth-shell/{}" \;)
+}