summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordiamondop12342021-11-09 17:50:58 +0400
committerdiamondop12342021-11-09 17:50:58 +0400
commit8ebdc399ced6a3543daa4eea2a37735ff8608212 (patch)
tree4901f08a983bd4dbc8c95553c4542e8669d173cd
downloadaur-8ebdc399ced6a3543daa4eea2a37735ff8608212.tar.gz
Initial commit for SynthV Studio
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--synthv-studio.sh3
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2733179978bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = synthv-studio
+ pkgdesc = Synthesizer V studio by Dreamtonics
+ pkgver = 1
+ pkgrel = 1
+ url = https://dreamtonics.com/synthesizerv
+ arch = x86_64
+ license = custom
+ provides = synthv-studio
+ conflicts = synthv-studio
+ source = https://resource.dreamtonics.com/download/Synthesizer%20V%20Studio%20Basic/latest/svstudio-basic-linux64-latest.zip
+ source = synthv-studio.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = synthv-studio
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e781bffce4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Denshi <alex@denshi.org>
+
+pkgname=synthv-studio
+pkgver=1
+pkgrel=1
+pkgdesc="Synthesizer V studio by Dreamtonics"
+arch=("x86_64")
+url=https://dreamtonics.com/synthesizerv
+license=(custom)
+depends=()
+provides=("synthv-studio")
+conflicts=("synthv-studio")
+source=("https://resource.dreamtonics.com/download/Synthesizer%20V%20Studio%20Basic/latest/svstudio-basic-linux64-latest.zip"
+ "synthv-studio.sh")
+sha256sums=("SKIP"
+ "SKIP")
+
+
+build() {
+ chmod +x "${srcdir}/Synthesizer V Studio Basic/synthv-studio"
+}
+
+package() {
+ install -d "${pkgdir}/opt/synthv-studio"
+ cp -r "${srcdir}/Synthesizer V Studio Basic/." "${pkgdir}/opt/synthv-studio"
+
+ install -Dm755 "${srcdir}/synthv-studio.sh" "${pkgdir}/usr/bin/synthv-studio"
+
+}
diff --git a/synthv-studio.sh b/synthv-studio.sh
new file mode 100644
index 000000000000..e4ae9f6d5e54
--- /dev/null
+++ b/synthv-studio.sh
@@ -0,0 +1,3 @@
+#!/usr/bin/sh
+cd /opt/synthv-studio
+./synthv-studio