summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNyaacinth2022-03-15 19:39:39 +0800
committerNyaacinth2022-03-15 19:39:39 +0800
commit81b30f1cd70f675d6f3b254d5e4056325b4a9202 (patch)
treee0407c8f7ab5d3fc31c607074eddc8cef97d113d
downloadaur-81b30f1cd70f675d6f3b254d5e4056325b4a9202.tar.gz
Init Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--synthv-studio.desktop8
-rw-r--r--synthv-studio.pngbin0 -> 6746 bytes
-rwxr-xr-xsynthv-studio.sh19
5 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..371e0474a85a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = synthv-studio-bin
+ pkgdesc = Synthesizer V studio by Dreamtonics
+ pkgver = 1
+ pkgrel = 1
+ url = https://dreamtonics.com/synthesizerv
+ arch = x86_64
+ license = custom
+ provides = synthv-studio
+ source = synthv-studio.sh
+ source = synthv-studio.png
+ source = synthv-studio.desktop
+ sha256sums = 83a419a9c281fbca976bc683ba584a7e0bf4ac5cc249c3a0ed0cfff92f2215af
+ sha256sums = f0f0180bbd5a029655089c5f8d5948c093622dd978e8aa6a4c47689b5936351b
+ sha256sums = 710f95ca38ab0e69c0431feb7f323bf84b4b4b822248a465ed5e525b36070871
+
+pkgname = synthv-studio-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c909bfe18544
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nyaacinth <nyaacinth_liota@outlook.com>
+pkgname=synthv-studio-bin
+pkgver=1
+pkgrel=1
+pkgdesc="Synthesizer V studio by Dreamtonics"
+arch=("x86_64")
+url="https://dreamtonics.com/synthesizerv"
+license=(custom)
+depends=()
+provides=("synthv-studio")
+conflicts=()
+source=("synthv-studio.sh"
+ "synthv-studio.png"
+ "synthv-studio.desktop")
+sha256sums=("83a419a9c281fbca976bc683ba584a7e0bf4ac5cc249c3a0ed0cfff92f2215af"
+ "f0f0180bbd5a029655089c5f8d5948c093622dd978e8aa6a4c47689b5936351b"
+ "710f95ca38ab0e69c0431feb7f323bf84b4b4b822248a465ed5e525b36070871")
+
+package() {
+ read -p "Please input the path to your Synthesizer V Studio distribution (the zip file you downloaded) on the filesystem: " SVDIST
+ install -Dm644 "${SVDIST}" "${pkgdir}/opt/synthv-studio/dist.zip"
+ install -Dm644 "${srcdir}/synthv-studio.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/synthv-studio.png"
+ install -Dm755 "${srcdir}/synthv-studio.sh" "${pkgdir}/usr/bin/synthv-studio"
+ install -Dm755 "${srcdir}/synthv-studio.desktop" "${pkgdir}/usr/share/applications/synthv-studio.desktop"
+}
diff --git a/synthv-studio.desktop b/synthv-studio.desktop
new file mode 100644
index 000000000000..c2ea5d504bc0
--- /dev/null
+++ b/synthv-studio.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Synthesizer V Studio
+Terminal=false
+Type=Application
+Comment=All you need for a high-quality singing synthesis software
+Exec=/usr/bin/synthv-studio
+Icon=synthv-studio
+Categories=AudioVideo;
diff --git a/synthv-studio.png b/synthv-studio.png
new file mode 100644
index 000000000000..89da695f5a3c
--- /dev/null
+++ b/synthv-studio.png
Binary files differ
diff --git a/synthv-studio.sh b/synthv-studio.sh
new file mode 100755
index 000000000000..8d1739890619
--- /dev/null
+++ b/synthv-studio.sh
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+set -e
+
+SVPACKAGE="/opt/synthv-studio/dist.zip"
+SVPREFIX="$HOME/.synthv-studio"
+
+if [ ! -d "$SVPREFIX" ]; then
+ mkdir "$SVPREFIX"
+fi
+cd "$SVPREFIX"
+if [ ! -f "./_installed" ]; then
+ echo "Installing..."
+ SVTYPE=`bsdtar -tf "$SVPACKAGE" | head -1`
+ bsdtar -xf "$SVPACKAGE"
+ mv "./$SVTYPE/"* "."
+ rmdir "./$SVTYPE"
+ touch "./_installed"
+fi
+exec "./synthv-studio"