summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorheinrich59912018-09-25 13:20:31 +0200
committerheinrich59912018-09-25 13:20:31 +0200
commit378548d16471a96d4644de80330fc1a87e6ccd89 (patch)
treebe895dfd7e3bff3b1cf1d5180f780308f71148ff
parenta595e34b524ce4882ca09bfb579b73f7ca0decf8 (diff)
downloadaur-378548d16471a96d4644de80330fc1a87e6ccd89.tar.gz
Fix compilation
The include directory for SDL was somehow missing from the command line.
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD4
3 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a58bbbec3036..64bf383e3602 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syobon
pkgdesc = A free version of the unforgiving Japanese parody of Super Mario Bros
pkgver = rc1
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/projects/opensyobon/
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5fdc46c8c82d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
index 9dcf2315da13..e310337c982e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: heinrich5991 <heinrich5991@gmail.com>
pkgname=syobon
pkgver=rc1
-pkgrel=1
+pkgrel=2
pkgdesc="A free version of the unforgiving Japanese parody of Super Mario Bros"
arch=('i686' 'x86_64')
url="http://sourceforge.net/projects/opensyobon/"
@@ -17,7 +17,7 @@ sha256sums=('c749349348357eeca4c9a1e150d5f32a40d5e11517d46840cba0c777fa788885'
build() {
cd "$srcdir/src/"
- sed -i 's/gcc/g++/g' "Makefile"
+ sed -i 's/gcc/g++ -Wno-narrowing `sdl-config --cflags`/g' Makefile
make
}