summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine1632019-02-27 01:31:33 +0100
committerantoine1632019-02-27 01:31:33 +0100
commita08faef834c1f4bf3bee01f1cba482de74d91d9f (patch)
tree1ee5a5e3e7e705ebd55062192366fd0a2f60ae83
downloadaur-a08faef834c1f4bf3bee01f1cba482de74d91d9f.tar.gz
Firt pkgbuild
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c538204c9c61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sys-pc-tool
+ pkgdesc = SYS PC Tool is a software for downloading flights recorded inside Syrides instruments.
+ pkgver = 6.12
+ pkgrel = 1
+ url = https://www.syride.com/
+ arch = x86_64
+ license = unknown
+ depends = glibc>=2.17
+ depends = krb5>=1.10
+ depends = libldap
+ depends = gtk2
+ depends = libusb
+ depends = libxml2
+ depends = p11-kit
+ depends = openssl
+ source = https://www.syride.com/downloads/sys-pc-tool-6.12-1_amd64.deb
+ md5sums = d89f77649a1cf094a5f6821b4170de03
+
+pkgname = sys-pc-tool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fb110e42109
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Antoine Maleyrie <antoine.maleyrie@gmail.com>
+
+pkgname=sys-pc-tool
+pkgver=6.12
+pkgrel=1
+
+pkgdesc="SYS PC Tool is a software for downloading flights recorded inside Syrides instruments."
+arch=('x86_64')
+url="https://www.syride.com/"
+license=('unknown')
+depends=('glibc>=2.17' 'krb5>=1.10' 'libldap' 'gtk2' 'libusb' 'libxml2' 'p11-kit' 'openssl')
+#install=
+source=("https://www.syride.com/downloads/$pkgname-$pkgver-$pkgrel""_amd64.deb")
+md5sums=('d89f77649a1cf094a5f6821b4170de03')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ cp -r "usr/local/" "$pkgdir/usr/"
+
+ mkdir -p "$pkgdir/usr/local/share/"
+ cp -r "usr/local/share/syride/" "$pkgdir/usr/local/share/"
+
+ mkdir -p "$pkgdir/etc/udev/rules.d/"
+ cp "lib/udev/rules.d/96-syride.rules" "$pkgdir/etc/udev/rules.d/"
+
+ # To update udev ruls:
+ # $ udevadm control --reload
+ # $ udevadm trigger
+}