summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2023-02-19 21:06:07 +0000
committerJoan Bruguera2023-02-19 21:06:07 +0000
commit618ba1b98d17aa08630afd07b23daa96296d3cb4 (patch)
tree80622e7c50bbe85e68708f618187c09479583c54
parent7b52b56136e48b9cb4657e5eb79a5c3b257e3eff (diff)
downloadaur-618ba1b98d17aa08630afd07b23daa96296d3cb4.tar.gz
Migrate to protoc-gen-go-grpc to stop depending on broken and obsolescent protobuf-go AUR package
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c4a5c1c42ff..9a131ef8c7f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ install=install.sh
provides=('sysbox-ce')
conflicts=('sysbox-ce')
depends=('rsync' 'fuse2')
-makedepends=('git' 'go' 'protobuf' 'protobuf-go')
+makedepends=('git' 'go' 'protobuf' 'protoc-gen-go-grpc')
# Those next makedepends are not *actually* needed but the build process tries to launch them anyway
makedepends+=('lsb-release' 'inetutils')
optdepends=('shiftfs: For uid-mapping on very old kernels without idmapped-mounts')
@@ -57,6 +57,12 @@ prepare() {
# Get some non-binary files from the Debian package as they don't seem to be uploaded anywhere else
mkdir -p data
tar xf data.tar.xz -C data
+
+ # Migrate to the new protoc-gen-go-grpc generator. Set require_unimplemented_servers=false for compatibility:
+ # https://github.com/grpc/grpc-go/blob/abff344ead8f49f3a89ae8be68b1538611950ec4/cmd/protoc-gen-go-grpc/README.md
+ sed -i 's/--go_out=plugins=grpc:./--go_out=. --go-grpc_out=. --go-grpc_opt=require_unimplemented_servers=false/g' \
+ sysbox/sysbox-ipc/sysboxFsGrpc/sysboxFsProtobuf/Makefile \
+ sysbox/sysbox-ipc/sysboxMgrGrpc/sysboxMgrProtobuf/Makefile
}
build() {