summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2017-09-28 09:11:52 +0200
committerÓscar García Amor2017-09-28 09:11:52 +0200
commit3868fe3adea27a0e06c297384534c806e00a73d1 (patch)
tree684a456a1dbf50c1c0642fce16c5191700beba63
downloadaur-3868fe3adea27a0e06c297384534c806e00a73d1.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d361490f9dcd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = sysdig-inspect
+ pkgdesc = A powerful opensource interface for container troubleshooting and security investigation
+ pkgver = 0.1.42
+ pkgrel = 1
+ url = https://github.com/draios/sysdig-inspect
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = expat
+ depends = gconf
+ depends = gtk2
+ depends = gvfs
+ depends = hunspell
+ depends = hunspell-en
+ depends = libcurl-compat
+ depends = libgcrypt
+ depends = libgnome-keyring
+ depends = libnotify
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ optdepends = gnome-keyring
+ source = https://download.sysdig.com/stable/sysdig-inspect/sysdig-inspect_0.1.42_amd64.deb
+ sha256sums = 1790d7a4b6c6b618b1618c1767ad7b0ba4a1cf4b61e6a252c075f27488b93bec
+
+pkgname = sysdig-inspect
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cb5362cd171
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname=sysdig-inspect
+pkgver=0.1.42
+pkgrel=1
+pkgdesc="A powerful opensource interface for container troubleshooting and security investigation"
+arch=('x86_64')
+url="https://github.com/draios/sysdig-inspect"
+license=('custom')
+depends=('alsa-lib' 'expat' 'gconf' 'gtk2' 'gvfs' 'hunspell' 'hunspell-en' 'libcurl-compat' 'libgcrypt' 'libgnome-keyring' 'libnotify' 'libxss' 'libxtst' 'xdg-utils')
+optdepends=('gnome-keyring')
+source=("https://download.sysdig.com/stable/sysdig-inspect/${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('1790d7a4b6c6b618b1618c1767ad7b0ba4a1cf4b61e6a252c075f27488b93bec')
+
+package() {
+ bsdtar -O -xf "${pkgname}_${pkgver}"*.deb data.tar.xz | bsdtar -C "$pkgdir" -xJf -
+
+ # Permission fix
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ # Remove all unnecessary stuff
+ rm -rf "${pkgdir}/usr/share/lintian"
+ rm -rf "${pkgdir}/usr/share/doc"
+
+ # Install license
+ install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s /usr/lib/${pkgname}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+}