summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2016-11-18 20:04:31 +0100
committerÓscar García Amor2016-11-18 20:04:31 +0100
commit0eb6608526de1eda1f1089dfbdd2c09d1f666301 (patch)
tree0d2ffc1d363bab92e68da8213d6c0af864522122
downloadaur-0eb6608526de1eda1f1089dfbdd2c09d1f666301.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--sysdweb.patch13
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89729607de85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sysdweb
+ pkgdesc = Control systemd services through Web or REST API
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ogarcia/sysdweb
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = python-bottle
+ depends = python-dbus
+ backup = etc/sysdweb.conf
+ source = https://github.com/ogarcia/sysdweb/archive/0.1.tar.gz
+ sha256sums = d780c5628b0d8bf671681d0291b98e9faa0a45ee2f18629d071557e9b8c7334f
+
+pkgname = sysdweb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..88f2f69edbb3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!sysdweb.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b03d827d69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname=sysdweb
+pkgver=0.1
+pkgrel=1
+pkgdesc='Control systemd services through Web or REST API'
+arch=('any')
+url='https://github.com/ogarcia/sysdweb'
+license=('GPL')
+depends=('python-bottle' 'python-dbus')
+makedepends=('python-setuptools' 'python2-setuptools')
+backup=("etc/${pkgname}.conf")
+source=("https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}.patch")
+sha256sums=('d780c5628b0d8bf671681d0291b98e9faa0a45ee2f18629d071557e9b8c7334f'
+ '14764eebefa1a1037f915033cc3523a9140cd5066287315c8997cde5551a0148')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/${pkgname}.patch"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize='1'
+
+ # config file
+ install -D -m644 "${pkgname}.conf" \
+ "${pkgdir}/etc/${pkgname}.conf"
+
+ # doc file
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+
+ # service files
+ install -D -m644 "systemd/${pkgname}-system.service" \
+ "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -D -m644 "systemd/${pkgname}-user.service" \
+ "${pkgdir}/usr/lib/systemd/user/${pkgname}.service"
+}
diff --git a/sysdweb.patch b/sysdweb.patch
new file mode 100644
index 000000000000..dd067943c157
--- /dev/null
+++ b/sysdweb.patch
@@ -0,0 +1,13 @@
+--- a/setup.py 2016-11-18 18:25:40.675267465 +0100
++++ b/setup.py 2016-11-18 19:53:50.949739754 +0100
+@@ -40,10 +40,6 @@
+ 'sysdweb = sysdweb.main:main'
+ ]
+ },
+- install_requires = [
+- "bottle>=0.12.10",
+- "dbus-python>=1.2.4"
+- ],
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Utilities",