summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2016-11-22 17:12:39 +0100
committerÓscar García Amor2016-11-22 17:12:39 +0100
commit6761d0c65cdcddba7caf9413b2e9c700d4380c0b (patch)
tree434ae17d2c93778e25be316e13d8a64a75b0423b
parent96ea8cf0ced077848488848d7a38bd328fa4eb61 (diff)
downloadaur-6761d0c65cdcddba7caf9413b2e9c700d4380c0b.tar.gz
Updated to 1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--sysdweb.patch13
3 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72b281246713..8d0e55854962 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sysdweb
pkgdesc = Control systemd services through Web or REST API
- pkgver = 0.2
+ pkgver = 1.0
pkgrel = 2
url = https://github.com/ogarcia/sysdweb
arch = any
@@ -8,11 +8,10 @@ pkgbase = sysdweb
makedepends = python-setuptools
depends = python-bottle
depends = python-dbus
+ depends = python-systemd
backup = etc/sysdweb.conf
- source = https://github.com/ogarcia/sysdweb/archive/0.2.tar.gz
- source = sysdweb.patch
- sha256sums = 754c9824c56611ff930256c3e230315bf2c59125f56a1dce45b7cccb6b62ed4f
- sha256sums = 14764eebefa1a1037f915033cc3523a9140cd5066287315c8997cde5551a0148
+ source = https://github.com/ogarcia/sysdweb/archive/1.0.tar.gz
+ sha256sums = 9ce4f870703761345f7117eee3e8f395ebf81d4192c2ce121610a65c6c188b0f
pkgname = sysdweb
diff --git a/PKGBUILD b/PKGBUILD
index 0e6d34848c2c..1132ad3e0083 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,17 @@
# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
pkgname=sysdweb
-pkgver=0.2
+pkgver=1.0
pkgrel=2
pkgdesc='Control systemd services through Web or REST API'
arch=('any')
url='https://github.com/ogarcia/sysdweb'
license=('GPL')
-depends=('python-bottle' 'python-dbus')
+depends=('python-bottle' 'python-dbus' 'python-systemd')
makedepends=('python-setuptools')
backup=("etc/${pkgname}.conf")
-source=("https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz"
- "${pkgname}.patch")
-sha256sums=('754c9824c56611ff930256c3e230315bf2c59125f56a1dce45b7cccb6b62ed4f'
- '14764eebefa1a1037f915033cc3523a9140cd5066287315c8997cde5551a0148')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/${pkgname}.patch"
-}
+source=("https://github.com/ogarcia/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('9ce4f870703761345f7117eee3e8f395ebf81d4192c2ce121610a65c6c188b0f')
package() {
cd "${pkgname}-${pkgver}"
diff --git a/sysdweb.patch b/sysdweb.patch
deleted file mode 100644
index dd067943c157..000000000000
--- a/sysdweb.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/setup.py 2016-11-18 18:25:40.675267465 +0100
-+++ b/setup.py 2016-11-18 19:53:50.949739754 +0100
-@@ -40,10 +40,6 @@
- 'sysdweb = sysdweb.main:main'
- ]
- },
-- install_requires = [
-- "bottle>=0.12.10",
-- "dbus-python>=1.2.4"
-- ],
- classifiers=[
- "Development Status :: 3 - Alpha",
- "Topic :: Utilities",