summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2021-09-26 22:37:27 +0200
committerLászló Várady2021-09-26 22:37:27 +0200
commit9b602b831413afd0102667ba879e29b378369242 (patch)
tree8424fcb0ef5c293c4524e9ad221d020e832a3245
parent744831d67d021b7a0fc529422c624829650d9d8b (diff)
downloadaur-syslog-ng-git.tar.gz
Add MQTT plugin
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19fac336dd47..f2bb000ccd66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = syslog-ng-git
pkgdesc = Enhanced system logging daemon
- pkgver = 3.29.1.r66.g088fc40ef
+ pkgver = 3.34.1.r22.ge18982343
pkgrel = 1
url = https://www.syslog-ng.com/products/open-source-log-management/
arch = x86_64
@@ -24,6 +24,7 @@ pkgbase = syslog-ng-git
makedepends = mongo-c-driver
makedepends = net-snmp
makedepends = librdkafka
+ makedepends = paho-mqtt-c
makedepends = python
makedepends = systemd
depends = systemd-libs
@@ -47,6 +48,7 @@ pkgbase = syslog-ng-git
optdepends = mongo-c-driver: for the MongoDB plugin
optdepends = net-snmp: for the SNMP plugin
optdepends = librdkafka: for the Kafka C plugin
+ optdepends = paho-mqtt-c: for the MQTT plugin
optdepends = python: for Python-based plugins
provides = syslog-ng
conflicts = syslog-ng
@@ -62,4 +64,3 @@ pkgbase = syslog-ng-git
sha256sums = SKIP
pkgname = syslog-ng-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 41f48a1e9d17..11ee40dc24b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=syslog-ng-git
_pkgname=syslog-ng
-pkgver=3.29.1.r66.g088fc40ef
+pkgver=3.34.1.r22.ge18982343
pkgrel=1
pkgdesc="Enhanced system logging daemon"
arch=('x86_64')
@@ -12,7 +12,7 @@ license=('GPL2' 'LGPL2.1')
depends=('systemd-libs' 'awk' 'glib2' 'ivykis' 'openssl' 'pcre' 'json-c' 'curl' 'libnet')
makedepends=('git' 'autoconf-archive' 'libxslt' 'docbook-xsl' 'json-c' 'curl' 'libdbi' 'libesmtp'
'hiredis' 'librabbitmq-c' 'riemann-c-client' 'libmaxminddb' 'mongo-c-driver'
- 'net-snmp' 'librdkafka' 'python' 'systemd')
+ 'net-snmp' 'librdkafka' 'paho-mqtt-c' 'python' 'systemd')
checkdepends=('criterion' 'python-nose' 'python-ply')
optdepends=('logrotate: for rotating log files'
'json-c: for the JSON plugin'
@@ -26,6 +26,7 @@ optdepends=('logrotate: for rotating log files'
'mongo-c-driver: for the MongoDB plugin'
'net-snmp: for the SNMP plugin'
'librdkafka: for the Kafka C plugin'
+ 'paho-mqtt-c: for the MQTT plugin'
'python: for Python-based plugins')
provides=("$_pkgname")
conflicts=("$_pkgname" 'eventlog')