summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2020-02-28 09:48:53 +0100
committerLászló Várady2020-02-28 09:48:53 +0100
commita934a1112ba884c6e05febe3b6569a85b42f17c1 (patch)
treecd8fabbe7fa573d54e5f2995b6e66b6945be2848
parent770f782f03bacdf648a8f3a62c41426c7c4949b3 (diff)
downloadaur-a934a1112ba884c6e05febe3b6569a85b42f17c1.tar.gz
Remove Java 8 support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34855ea995a9..793556a8d850 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = syslog-ng-git
pkgdesc = Enhanced system logging daemon
- pkgver = 3.22.1.r50.g7ccb0ab31
+ pkgver = 3.25.1.r414.gb77db1817
pkgrel = 1
url = https://www.syslog-ng.com/products/open-source-log-management/
arch = x86_64
@@ -25,8 +25,6 @@ pkgbase = syslog-ng-git
makedepends = mongo-c-driver
makedepends = net-snmp
makedepends = librdkafka
- makedepends = java-environment=8
- makedepends = gradle
makedepends = python
depends = systemd-libs
depends = awk
@@ -50,7 +48,6 @@ pkgbase = syslog-ng-git
optdepends = mongo-c-driver: for the MongoDB plugin
optdepends = net-snmp: for the SNMP plugin
optdepends = librdkafka: for the Kafka C plugin
- optdepends = java-runtime-headless: for Java-based plugins
optdepends = python: for Python-based plugins
provides = syslog-ng
conflicts = syslog-ng
diff --git a/PKGBUILD b/PKGBUILD
index 5c18347360e1..f4d62d70136c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=syslog-ng-git
_pkgname=syslog-ng
-pkgver=3.22.1.r50.g7ccb0ab31
+pkgver=3.25.1.r414.gb77db1817
pkgrel=1
pkgdesc="Enhanced system logging daemon"
arch=('x86_64')
@@ -12,7 +12,7 @@ license=('GPL2' 'LGPL2.1')
depends=('systemd-libs' 'awk' 'glib2' 'ivykis' 'openssl' 'pcre' 'json-c' 'curl' 'libnet')
makedepends=('git' 'autoconf-archive' 'libxslt' 'docbook-xsl' 'json-c' 'curl' 'libdbi' 'libesmtp'
'hiredis' 'librabbitmq-c' 'riemann-c-client' 'geoip' 'libmaxminddb' 'mongo-c-driver'
- 'net-snmp' 'librdkafka' 'java-environment=8' 'gradle' 'python')
+ 'net-snmp' 'librdkafka' 'python')
checkdepends=('criterion' 'python-nose' 'python-ply')
optdepends=('logrotate: for rotating log files'
'json-c: for the JSON plugin'
@@ -27,7 +27,6 @@ optdepends=('logrotate: for rotating log files'
'mongo-c-driver: for the MongoDB plugin'
'net-snmp: for the SNMP plugin'
'librdkafka: for the Kafka C plugin'
- 'java-runtime-headless: for Java-based plugins'
'python: for Python-based plugins')
provides=("$_pkgname")
conflicts=("$_pkgname" 'eventlog')
@@ -59,7 +58,8 @@ build() {
--sbindir=/usr/bin --localstatedir=/var/lib/syslog-ng --datadir=/usr/share \
--with-pidfile-dir=/run --with-jsonc=system --with-ivykis=system \
--enable-all-modules --enable-ipv6 --enable-pacct --enable-manpages \
- --enable-systemd --with-systemdsystemunitdir=/usr/lib/systemd/system
+ --enable-systemd --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --disable-java --disable-java-modules
make
}