summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2019-06-15 09:47:33 +0300
committerAlexey D2019-06-15 09:47:33 +0300
commit1758d0178ddb05afc6a281e5853b3466d13d8226 (patch)
tree7c7683e6b307a8dfd41e8a3e22e639cf07f2874a
parentf23228210e9a333d0e70e2ddfd23f4ce00ee6d69 (diff)
downloadaur-1758d0178ddb05afc6a281e5853b3466d13d8226.tar.gz
version 3.21.1-1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD45
-rw-r--r--syslog-ng.conf2
3 files changed, 46 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22cda0c731cd..234d450575d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 22 05:36:52 UTC 2019
+# Sat Jun 15 06:46:49 UTC 2019
pkgbase = syslog-ng-nosystemd
pkgdesc = Next-generation syslogd with advanced networking and filtering capabilities
- pkgver = 3.20.1
- pkgrel = 2
+ pkgver = 3.21.1
+ pkgrel = 1
url = https://www.syslog-ng.com/products/open-source-log-management/
arch = i686
arch = x86_64
@@ -13,28 +13,34 @@ pkgbase = syslog-ng-nosystemd
makedepends = flex
makedepends = pkg-config
makedepends = libxslt
- makedepends = json-c
makedepends = mongo-c-driver
makedepends = librabbitmq-c
makedepends = python
makedepends = libesmtp
makedepends = hiredis
+ makedepends = libdbi
+ makedepends = geoip
+ makedepends = libmaxminddb
depends = awk
depends = glib2
depends = libcap
- depends = libdbi
depends = libnsl
depends = udev
+ depends = json-c
+ depends = curl
+ depends = libnet
optdepends = logrotate: for rotating log files
- optdepends = json-c: for json-plugin
- optdepends = curl: for the HTTP module
+ optdepends = libdbi: for the SQL plugin
optdepends = librabbitmq-c: for the AMQP plugin
optdepends = mongo-c-driver: for the MongoDB plugin
optdepends = python: for the Python plugin
optdepends = libesmtp: for the SMTP plugin
optdepends = hiredis: fir the redis plugin
+ optdepends = geoip: for the GeoIP plugin
+ optdepends = libmaxminddb: for the GeoIP2 plugin
+ optdepends = python: for Python-based plugins
optdepends = syslog-ng-openrc: syslog-ng openrc initscript
- provides = syslog-ng=3.20.1
+ provides = syslog-ng=3.21.1
conflicts = syslog-ng
conflicts = syslog-ng-eudev
conflicts = eventlog
@@ -45,13 +51,13 @@ pkgbase = syslog-ng-nosystemd
backup = etc/syslog-ng/syslog-ng.conf
backup = etc/conf.d/initscripts/syslog-ng
backup = etc/logrotate.d/syslog-ng
- source = https://github.com/balabit/syslog-ng/releases/download/syslog-ng-3.20.1/syslog-ng-3.20.1.tar.gz
+ source = https://github.com/balabit/syslog-ng/releases/download/syslog-ng-3.21.1/syslog-ng-3.21.1.tar.gz
source = syslog-ng.conf
source = syslog-ng.conf.d
source = syslog-ng.logrotate
source = syslog-ng.rc
- sha256sums = a65858afe9c649119a23ff61669945cab8692a045ee8259e8ee666445c8fbda0
- sha256sums = 52c8d7bfbc6a360b6cdc03dcb15d43c08b8940f672cdaa584b5d05c0a0bf3d74
+ sha256sums = 8d163da5ad79cf3a5f043b2ed0fe18a4888d0d740542703bf2508f0b9996cd25
+ sha256sums = 9175deae0b16c0c8a501919c533695254afefd52daf1dae229077cd8f71d0cd9
sha256sums = fe6ebe5c281b34bad201d9206e607857db9a5a78f03bb4dc4440584dca610f61
sha256sums = 93c935eca56854011ea9e353b7a1da662ad40b2e8452954c5b4b5a1d5b2d5317
sha256sums = db643d69e840dfd5d7849e857291f15fd60913527402fde806ce3911e3523063
diff --git a/PKGBUILD b/PKGBUILD
index c1604e2d55b5..ab8d26828cd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,26 @@
# Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=syslog-ng-nosystemd
-pkgver=3.20.1
-pkgrel=2
+pkgver=3.21.1
+pkgrel=1
pkgdesc="Next-generation syslogd with advanced networking and filtering capabilities"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
groups=('eudev-base')
url="https://www.syslog-ng.com/products/open-source-log-management/"
-depends=('awk' 'glib2' 'libcap' 'libdbi' 'libnsl' 'udev')
-makedepends=('flex' 'pkg-config' 'libxslt' 'json-c' 'mongo-c-driver'
- 'librabbitmq-c' 'python' 'libesmtp' 'hiredis')
+depends=('awk' 'glib2' 'libcap' 'libnsl' 'udev' 'json-c' 'curl' 'libnet')
+makedepends=('flex' 'pkg-config' 'libxslt' 'mongo-c-driver' 'librabbitmq-c'
+ 'python' 'libesmtp' 'hiredis' 'libdbi' 'geoip' 'libmaxminddb')
optdepends=('logrotate: for rotating log files'
- 'json-c: for json-plugin'
- 'curl: for the HTTP module'
+ 'libdbi: for the SQL plugin'
'librabbitmq-c: for the AMQP plugin'
'mongo-c-driver: for the MongoDB plugin'
'python: for the Python plugin'
'libesmtp: for the SMTP plugin'
'hiredis: fir the redis plugin'
+ 'geoip: for the GeoIP plugin'
+ 'libmaxminddb: for the GeoIP2 plugin'
+ 'python: for Python-based plugins'
'syslog-ng-openrc: syslog-ng openrc initscript')
provides=("syslog-ng=${pkgver}")
replaces=('syslog-ng' 'syslog-ng-eudev' 'eventlog')
@@ -35,15 +37,26 @@ source=(https://github.com/balabit/syslog-ng/releases/download/syslog-ng-$pkgver
syslog-ng.conf.d
syslog-ng.logrotate
syslog-ng.rc)
-sha256sums=('a65858afe9c649119a23ff61669945cab8692a045ee8259e8ee666445c8fbda0'
- '52c8d7bfbc6a360b6cdc03dcb15d43c08b8940f672cdaa584b5d05c0a0bf3d74'
+sha256sums=('8d163da5ad79cf3a5f043b2ed0fe18a4888d0d740542703bf2508f0b9996cd25'
+ '9175deae0b16c0c8a501919c533695254afefd52daf1dae229077cd8f71d0cd9'
'fe6ebe5c281b34bad201d9206e607857db9a5a78f03bb4dc4440584dca610f61'
'93c935eca56854011ea9e353b7a1da662ad40b2e8452954c5b4b5a1d5b2d5317'
'db643d69e840dfd5d7849e857291f15fd60913527402fde806ce3911e3523063')
+prepare() {
+ cd "syslog-ng-$pkgver"
+
+ # the version in pkg-config is 0.0.0 and so it won't detect the flags without
+ # this. since your version is newer this is an easy fix for now, but should
+ # eventually be removed when this bug is fixed:
+ # https://bugs.archlinux.org/task/61888
+ sed -i -e 's|^LMC_MIN_VERSION="1.0.0"|LMC_MIN_VERSION="0.0.0"|' configure.ac configure
+}
+
build() {
cd "syslog-ng-$pkgver"
+ ./autogen.sh
./configure \
--prefix=/usr \
--sysconfdir=/etc/syslog-ng \
@@ -52,14 +65,15 @@ build() {
--localstatedir=/var/lib/syslog-ng \
--datadir=/usr/share \
--with-pidfile-dir=/run \
- --disable-spoof-source \
+ --enable-spoof-source \
--enable-ipv6 \
- --enable-sql \
- --enable-smtp \
--enable-manpages \
+ --enable-all-modules \
+ --disable-java \
+ --disable-java-modules \
+ --disable-riemann \
+ --with-python=3 \
--with-jsonc=system \
- --with-mongoc=system \
- --with-librabbitmq-client=system \
--disable-systemd
make
@@ -73,7 +87,4 @@ package() {
install -Dm644 "$srcdir/syslog-ng.logrotate" "$pkgdir/etc/logrotate.d/syslog-ng"
install -Dm755 "$srcdir/syslog-ng.rc" "$pkgdir/etc/rc.d/syslog-ng"
install -Dm644 "$srcdir/syslog-ng.conf.d" "$pkgdir/etc/conf.d/initscripts/syslog-ng"
-
- # See http://lists.balabit.hu/pipermail/syslog-ng/2016-February/022667.html
- rm -r "$pkgdir/usr/share/syslog-ng/include/scl/cim"
}
diff --git a/syslog-ng.conf b/syslog-ng.conf
index 1043981177a6..f764684a804e 100644
--- a/syslog-ng.conf
+++ b/syslog-ng.conf
@@ -1,4 +1,4 @@
-@version: 3.20
+@version: 3.21
@include "scl.conf"
#
# /etc/syslog-ng/syslog-ng.conf