summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2019-03-21 08:59:24 +0300
committerAlexey D2019-03-21 08:59:24 +0300
commit5e78f1592154aa166f5231380a56af946055f820 (patch)
tree442ecfe6ef5dfa6c067632f4c2a07fe944a57955
parent96daf5ea66576603e842e75bc1d4f66be00fd51b (diff)
downloadaur-5e78f1592154aa166f5231380a56af946055f820.tar.gz
version 3.20.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--2251fa7a.patch64
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 977610a8c231..d0fa197303a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Mar 3 05:51:35 UTC 2019
+# Thu Mar 21 05:59:08 UTC 2019
pkgbase = syslog-ng-nosystemd
pkgdesc = Next-generation syslogd with advanced networking and filtering capabilities
- pkgver = 3.19.1
- pkgrel = 3
+ pkgver = 3.20.1
+ pkgrel = 1
url = https://www.syslog-ng.com/products/open-source-log-management/
arch = i686
arch = x86_64
@@ -34,7 +34,7 @@ pkgbase = syslog-ng-nosystemd
optdepends = libesmtp: for the SMTP plugin
optdepends = hiredis: fir the redis plugin
optdepends = syslog-ng-openrc: syslog-ng openrc initscript
- provides = syslog-ng=3.19.1
+ provides = syslog-ng=3.20.1
conflicts = syslog-ng
conflicts = syslog-ng-eudev
conflicts = eventlog
@@ -45,12 +45,12 @@ pkgbase = syslog-ng-nosystemd
backup = etc/syslog-ng/syslog-ng.conf
backup = etc/conf.d/initscripts/syslog-ng
backup = etc/logrotate.d/syslog-ng
- source = https://github.com/balabit/syslog-ng/releases/download/syslog-ng-3.19.1/syslog-ng-3.19.1.tar.gz
+ source = https://github.com/balabit/syslog-ng/releases/download/syslog-ng-3.20.1/syslog-ng-3.20.1.tar.gz
source = syslog-ng.conf
source = syslog-ng.conf.d
source = syslog-ng.logrotate
source = syslog-ng.rc
- sha256sums = 5cf931a9d7bead0e6d9a2c65eee8f6005a005878f59aa280f3c4294257ed5178
+ sha256sums = a65858afe9c649119a23ff61669945cab8692a045ee8259e8ee666445c8fbda0
sha256sums = 0610bc3900453329c1ea68f3ad5a4ef49b8f4d2199e1a380389adcc760babf34
sha256sums = fe6ebe5c281b34bad201d9206e607857db9a5a78f03bb4dc4440584dca610f61
sha256sums = 93c935eca56854011ea9e353b7a1da662ad40b2e8452954c5b4b5a1d5b2d5317
diff --git a/2251fa7a.patch b/2251fa7a.patch
deleted file mode 100644
index 9efeac6226ba..000000000000
--- a/2251fa7a.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 2251fa7a2239abeb6c5087fcee71a5d8869d9f6f Mon Sep 17 00:00:00 2001
-From: Balazs Scheidler <balazs.scheidler@balabit.com>
-Date: Mon, 6 Feb 2017 19:50:18 +0100
-Subject: [PATCH] tlscontext: fix segfault in X509_STORE_CTX_get_app_data(ctx)
-
-This patch fixes a potential segfault during X.509 certificate validation.
-What happens is that X509_STORE_CTX contains "application data", e.g.
-the application is able to associate a series of pointers with the validation.
-
-This uses an "id" to identify the user of the specific pointer.
-
-This mechanism is used by the SSL library (still in openssl) to store the
-pointer to the SSL session. The ID for this data is normally 0, however
-if libssl.so is unloaded while libcrypto.so is not, it might happen
-that this ID gets remapped to a non-zero value.
-
-Then what leads to the crash is that libssl starts to use ID 1
-to manage its SSL* pointer, while we in the validation code still
-use ID 0, causing a NULL deref.
-
-The exact reasons why this ID change happens is unclear, some apache
-related information can be found here:
-
-https://bz.apache.org/bugzilla/show_bug.cgi?id=32529
-
-You can also find more information in github issue #1310.
-
-Signed-off-by: Peter Gervai <grin@grin.hu>
-Signed-off-by: Balazs Scheidler <balazs.scheidler@balabit.com>
----
- lib/tlscontext.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/lib/tlscontext.c b/lib/tlscontext.c
-index ff8e8df..95331f2 100644
---- a/lib/tlscontext.c
-+++ b/lib/tlscontext.c
-@@ -54,7 +54,7 @@ tls_get_x509_digest(X509 *x, GString *hash_string)
- int
- tls_session_verify_fingerprint(X509_STORE_CTX *ctx)
- {
-- SSL *ssl = X509_STORE_CTX_get_app_data(ctx);
-+ SSL *ssl = (SSL *)X509_STORE_CTX_get_ex_data(ctx, SSL_get_ex_data_X509_STORE_CTX_idx());
- TLSSession *self = SSL_get_app_data(ssl);
- GList *current_fingerprint = self->ctx->trusted_fingerpint_list;
- GString *hash;
-@@ -106,7 +106,7 @@ tls_x509_format_dn(X509_NAME *name, GString *dn)
- int
- tls_session_verify_dn(X509_STORE_CTX *ctx)
- {
-- SSL *ssl = X509_STORE_CTX_get_app_data(ctx);
-+ SSL *ssl = (SSL *)X509_STORE_CTX_get_ex_data(ctx, SSL_get_ex_data_X509_STORE_CTX_idx());
- TLSSession *self = SSL_get_app_data(ssl);
- gboolean match = FALSE;
- GList *current_dn = self->ctx->trusted_dn_list;
-@@ -179,7 +179,7 @@ tls_session_verify(TLSSession *self, int ok, X509_STORE_CTX *ctx)
- int
- tls_session_verify_callback(int ok, X509_STORE_CTX *ctx)
- {
-- SSL *ssl = X509_STORE_CTX_get_app_data(ctx);
-+ SSL *ssl = (SSL *)X509_STORE_CTX_get_ex_data(ctx, SSL_get_ex_data_X509_STORE_CTX_idx());
- TLSSession *self = SSL_get_app_data(ssl);
- /* NOTE: Sometimes libssl calls this function
- with no current_cert. This happens when
diff --git a/PKGBUILD b/PKGBUILD
index 0595bf5d814c..eaa055249632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=syslog-ng-nosystemd
-pkgver=3.19.1
-pkgrel=3
+pkgver=3.20.1
+pkgrel=1
pkgdesc="Next-generation syslogd with advanced networking and filtering capabilities"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
@@ -35,7 +35,7 @@ source=(https://github.com/balabit/syslog-ng/releases/download/syslog-ng-$pkgver
syslog-ng.conf.d
syslog-ng.logrotate
syslog-ng.rc)
-sha256sums=('5cf931a9d7bead0e6d9a2c65eee8f6005a005878f59aa280f3c4294257ed5178'
+sha256sums=('a65858afe9c649119a23ff61669945cab8692a045ee8259e8ee666445c8fbda0'
'0610bc3900453329c1ea68f3ad5a4ef49b8f4d2199e1a380389adcc760babf34'
'fe6ebe5c281b34bad201d9206e607857db9a5a78f03bb4dc4440584dca610f61'
'93c935eca56854011ea9e353b7a1da662ad40b2e8452954c5b4b5a1d5b2d5317'