summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2020-01-19 09:03:21 +0300
committerAlexey D2020-01-19 09:03:21 +0300
commit630f18d00e349db5ea93eff5324879884cc2a67f (patch)
tree49f74e6842e925506a4754338a45076cc9d536e9
parentdf5e2a94e851427760255bbb2e90573b1fcb68a6 (diff)
downloadaur-630f18d00e349db5ea93eff5324879884cc2a67f.tar.gz
upstream package update
Kafka plugin support removed duplicating optdepend
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c82a7ac4d2e1..c0a7a980b3d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = syslog-ng-nosystemd
pkgdesc = Next-generation syslogd with advanced networking and filtering capabilities
pkgver = 3.25.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.syslog-ng.com/products/open-source-log-management/
arch = i686
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = syslog-ng-nosystemd
makedepends = libdbi
makedepends = libmaxminddb
makedepends = net-snmp
+ makedepends = librdkafka
depends = awk
depends = glib2
depends = libcap
@@ -31,12 +32,12 @@ pkgbase = syslog-ng-nosystemd
optdepends = libdbi: for the SQL plugin
optdepends = librabbitmq-c: for the AMQP plugin
optdepends = mongo-c-driver: for the MongoDB plugin
- optdepends = python: for the Python plugin
optdepends = libesmtp: for the SMTP plugin
optdepends = hiredis: fir the redis plugin
optdepends = libmaxminddb: for the GeoIP2 plugin
optdepends = python: for Python-based plugins
optdepends = net-snmp: for the SNMP plugin
+ optdepends = librdkafka: for the Kafka C plugin
optdepends = syslog-ng-openrc: syslog-ng openrc initscript
provides = syslog-ng=3.25.1
conflicts = syslog-ng
diff --git a/PKGBUILD b/PKGBUILD
index 163bce3e2aec..1182e87422b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=syslog-ng-nosystemd
pkgver=3.25.1
-pkgrel=1
+pkgrel=2
pkgdesc="Next-generation syslogd with advanced networking and filtering capabilities"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
@@ -14,17 +14,18 @@ url="https://www.syslog-ng.com/products/open-source-log-management/"
depends=('awk' 'glib2' 'libcap' 'libnsl' 'udev' 'json-c' 'curl' 'libnet')
# we need latest mongo-c-driver build to make configure version check work correctly
makedepends=('flex' 'pkg-config' 'libxslt' 'mongo-c-driver>=1.14.0-3' 'librabbitmq-c'
- 'python' 'libesmtp' 'hiredis' 'libdbi' 'libmaxminddb' 'net-snmp')
+ 'python' 'libesmtp' 'hiredis' 'libdbi' 'libmaxminddb' 'net-snmp'
+ 'librdkafka')
optdepends=('logrotate: for rotating log files'
'libdbi: for the SQL plugin'
'librabbitmq-c: for the AMQP plugin'
'mongo-c-driver: for the MongoDB plugin'
- 'python: for the Python plugin'
'libesmtp: for the SMTP plugin'
'hiredis: fir the redis plugin'
'libmaxminddb: for the GeoIP2 plugin'
'python: for Python-based plugins'
'net-snmp: for the SNMP plugin'
+ 'librdkafka: for the Kafka C plugin'
'syslog-ng-openrc: syslog-ng openrc initscript')
provides=("syslog-ng=${pkgver}")
replaces=('syslog-ng' 'syslog-ng-eudev' 'eventlog')
@@ -73,7 +74,6 @@ build() {
--disable-java \
--disable-java-modules \
--disable-riemann \
- --disable-kafka \
--with-python=3 \
--with-jsonc=system \
--disable-systemd