summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert F. Nash2015-06-16 23:56:19 -0400
committerRobert F. Nash2015-06-16 23:56:19 -0400
commita33f72aace42b16a8f6ab62809457d6504bf85d2 (patch)
treee0d5b337d03382e308e92ab3f58a854f76cbaa64
downloadaur-a33f72aace42b16a8f6ab62809457d6504bf85d2.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--syslog-notify.install35
-rw-r--r--syslog-notify.patch12
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..499c3d2755e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = syslog-notify
+ pkgdesc = Pop-up display for system log messages
+ pkgver = 0.1
+ pkgrel = 2
+ url = http://jtniehof.github.com/syslog-notify
+ install = syslog-notify.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libnotify
+ source = http://cloud.github.com/downloads/jtniehof/syslog-notify/syslog-notify-0.1.tar.bz2
+ source = syslog-notify.patch
+ md5sums = 18474e11ceb0add6e8b70fe7680f0abf
+ md5sums = 3dc49b913d4ee1a00426fb993770084d
+
+pkgname = syslog-notify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d7a3ccf0517
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Filipp "Scorp" Andjelo <scorp@mailueberfall.de>
+
+pkgname=syslog-notify
+pkgver=0.1
+pkgrel=2
+pkgdesc="Pop-up display for system log messages"
+arch=('i686' 'x86_64')
+url="http://jtniehof.github.com/syslog-notify"
+license=('GPL')
+depends=('libnotify')
+install=${pkgname}.install
+source=(http://cloud.github.com/downloads/jtniehof/syslog-notify/${pkgname}-${pkgver}.tar.bz2
+ ${pkgname}.patch)
+md5sums=('18474e11ceb0add6e8b70fe7680f0abf'
+ '3dc49b913d4ee1a00426fb993770084d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 -i ${srcdir}/${pkgname}.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/syslog-notify.install b/syslog-notify.install
new file mode 100644
index 000000000000..8e0be577806e
--- /dev/null
+++ b/syslog-notify.install
@@ -0,0 +1,35 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+show_text() {
+cat<<EOF
+
+=== To use syslog-notify you must redirect syslog output to the pipe '/var/spool/syslog-notify'
+
+Example for syslog-ng (add to /etc/syslog-ng.conf):
+ destination d_syslog_notify { pipe("/var/spool/syslog-notify"); };
+ log { source(src); destination(d_syslog_notify); };
+
+Consult the manual of the syslog daemon used on your system for accordant information
+
+EOF
+}
+
+# arg 1: the new package version
+post_install() {
+ mkfifo /var/spool/syslog-notify
+ chmod a+rw /var/spool/syslog-notify
+ show_text
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ show_text
+}
+
+# arg 1: the old package version
+post_remove() {
+ rm /var/spool/syslog-notify
+ echo "==== If any syslog output redirection to the syslog-notify pipe was added, then don't forget to remove it"
+}
diff --git a/syslog-notify.patch b/syslog-notify.patch
new file mode 100644
index 000000000000..0253b849960a
--- /dev/null
+++ b/syslog-notify.patch
@@ -0,0 +1,12 @@
+diff -aur syslog-notify-0.1.pristine/src/syslog-notify.c syslog-notify-0.1.new/src/syslog-notify.c
+--- syslog-notify-0.1.pristine/src/syslog-notify.c 2011-03-31 16:11:18.509750668 +0300
++++ syslog-notify-0.1.new/src/syslog-notify.c 2011-03-31 16:11:42.286417334 +0300
+@@ -66,7 +66,7 @@
+ close(fd);
+ return;
+ }
+- notification=notify_notification_new(title,message,NULL,NULL);
++ notification=notify_notification_new(title,message,NULL);
+ notify_notification_set_timeout(notification,NOTIFY_EXPIRES_DEFAULT);
+ notify_notification_set_urgency(notification,NOTIFY_URGENCY_NORMAL);
+ notify_notification_set_hint_string(notification,"x-canonical-append",