summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Gardling2020-02-24 17:27:10 -0500
committerSimon Gardling2020-02-24 17:27:10 -0500
commit6714664af7232f2fa229022f9ae40d1222f64c36 (patch)
treedcef287bef4efccad0fc31075ca9209937245fed
parent648ab091188e326dc530613a35c0b80e7da9ba03 (diff)
downloadaur-6714664af7232f2fa229022f9ae40d1222f64c36.tar.gz
fix directory
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71355d5a9776..09127ea6bc05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = sysprof-dev
depends = polkit
depends = libdazzle
provides = sysprof
+ conflicts = sysprof
source = git+https://gitlab.gnome.org/GNOME/sysprof.git#tag=sysprof-3.35.3
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0227fcea372b..a269a4b01028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,18 +18,18 @@ conflicts=(sysprof)
pkgver() {
- cd $pkgname
+ cd sysprof
git describe --tags | sed 's/^sysprof-//;s/-/+/g'
}
prepare() {
- cd $pkgname
+ cd sysprof
}
build() {
CFLAGS+=" -ffat-lto-objects"
- arch-meson $pkgname build
+ arch-meson sysprof build
ninja -C build
}