summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2020-02-11 19:32:46 +0100
committerPellegrino Prevete2020-02-11 19:32:46 +0100
commitc9209e887723cc1ca84dfdf57d0fe2d95ffbcef2 (patch)
treee07b7dee7c4eb97dbf9bada070e49e9ccf7f02a7
parentb71f5af1153a5f3f0a09955bd33ecb014d1f60a4 (diff)
downloadaur-c9209e887723cc1ca84dfdf57d0fe2d95ffbcef2.tar.gz
Initial release
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD62
-rw-r--r--python2.patch8
3 files changed, 42 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a68678ae09a..78407584f624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,22 @@
-# Generated by mksrcinfo v8
-# Sat Oct 28 03:53:39 UTC 2017
-pkgbase = pcsxr-git
- pkgdesc = A Sony PlayStation emulator based on the PCSX-df Project
- pkgver = 1.9.94.r1697.6484236c
+pkgbase = system-config-users
+ pkgdesc = A graphical interface for administering users and groups
+ pkgver = 1.3.5
pkgrel = 1
- url = https://github.com/pcsxr/PCSX-Reloaded/tree/master/pcsxr
+ url = https://than.fedorapeople.org/system-config-users
arch = i686
arch = x86_64
license = GPL
- makedepends = cmake
- makedepends = git
- makedepends = intltool
- makedepends = mesa
- depends = ffmpeg
- depends = gdk-pixbuf2
- depends = glib2
- depends = glibc
- depends = gtk3
- depends = libarchive
- depends = libcdio
- depends = libgl
- depends = libpulse
- depends = libx11
- depends = libxext
- depends = libxtst
- depends = libxv
- depends = libxxf86vm
- depends = sdl2
- depends = zlib
- provides = pcsxr
- conflicts = pcsxr
- conflicts = pcsx-df
- replaces = pcsxr-svn
- source = pcsxr::git+https://github.com/pcsxr/PCSX-Reloaded.git
- sha256sums = SKIP
+ depends = libselinux-python2
+ depends = libuser
+ depends = python2
+ depends = python2-rpm
+ depends = selinux-python2
+ depends = rpm-tools
+ depends = xdg-utils
+ source = https://than.fedorapeople.org/system-config-users/system-config-users-1.3.5.tar.bz2
+ source = python2.patch
+ sha256sums = bec51eeb845cbbcfbbb42831b2f8b76a6ce56f30bf6ad33bee6aa4d1086a7cf2
+ sha256sums = 7eea5d2699b62839427c885af85633279d7db4ff2ef4867cc3b66220d59f5c0e
-pkgname = pcsxr-git
+pkgname = system-config-users
diff --git a/PKGBUILD b/PKGBUILD
index b8d408b41162..7d8546b24885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,36 @@
-# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
-# Contributor: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Infy <eugene.yudin@gmail.com>
-# Contributor: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Mantainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
-pkgname=pcsxr-git
-pkgver=1.9.94.r1697.6484236c
+pkgname=system-config-users
+pkgver=1.3.5
pkgrel=1
-pkgdesc='A Sony PlayStation emulator based on the PCSX-df Project'
+pkgdesc='A graphical interface for administering users and groups'
arch=('i686' 'x86_64')
-url='https://github.com/pcsxr/PCSX-Reloaded/tree/master/pcsxr'
+url='https://than.fedorapeople.org/system-config-users'
license=('GPL')
-depends=('ffmpeg' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libarchive' 'libcdio'
- 'libgl' 'libpulse' 'libx11' 'libxext' 'libxtst' 'libxv' 'libxxf86vm'
- 'sdl2' 'zlib')
-makedepends=('cmake' 'git' 'intltool' 'mesa')
-[[ $CARCH == i686 ]] && makedepends+=('nasm')
-provides=('pcsxr')
-conflicts=('pcsxr' 'pcsx-df')
-replaces=('pcsxr-svn')
-source=('pcsxr::git+https://github.com/pcsxr/PCSX-Reloaded.git')
-sha256sums=('SKIP')
+depends=('libselinux-python2' 'libuser' 'python2' 'python2-rpm' 'selinux-python2'
+ 'rpm-tools' 'xdg-utils')
+makedepends=()
+source=('https://than.fedorapeople.org/system-config-users/system-config-users-1.3.5.tar.bz2'
+ 'python2.patch')
+sha256sums=('bec51eeb845cbbcfbbb42831b2f8b76a6ce56f30bf6ad33bee6aa4d1086a7cf2'
+ '7eea5d2699b62839427c885af85633279d7db4ff2ef4867cc3b66220d59f5c0e')
-pkgver() {
- cd pcsxr
-
- echo "1.9.94.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
prepare() {
- cd pcsxr/pcsxr
-
- sed -i 's/iso9660/cdio/' cmake/FindCdio.cmake
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ SRC_PATH="${pkgname}-${pkgver}"
+ cp python2.patch $SRC_PATH
+ cd $SRC_PATH
+ patch -Np0 -i python2.patch
}
build() {
- cd pcsxr/pcsxr/build
+ cd "${pkgname}-${pkgver}"
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DSND_BACKEND='pulse' \
- -DENABLE_CCDDA='ON' \
- -DUSE_LIBARCHIVE='ON' \
- -DUSE_LIBCDIO='ON' \
- -DCMAKE_C_FLAGS_RELEASE:STRING="-O2 -DNDEBUG -mtune=native -pipe -I/usr/include/harfbuzz/ -lGLU -lGL " \
- -DCMAKE_CXX_FLAGS_RELEASE:STRING="-O2 -DNDEBUG -mtune=native -pipe -I/usr/include/harfbuzz/ -lGLU -lGL " \
- -DOpenGL_GL_PREFERENCE:STRING="GLVND"
make
}
package() {
- cd pcsxr/pcsxr/build
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..bcaa1916ad10
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,8 @@
+--- src/system-config-users.py 2013-08-13 11:09:05.000000000 +0200
++++ src/system-config-users.py.new 2020-02-11 19:23:42.054023217 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # -*- coding: utf-8 -*-
+ #
+ # system-config-users.py - this program calls mainWindow to start the GUI