summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-28 18:08:42 -0600
committerMark Wagie2022-04-28 18:08:42 -0600
commitcd8dd777fcc7cb5866e2798d6a35a6697723ff2b (patch)
treecc896c98726b8681bd67e86aaf33698903926d5a
parentef19b0981f2315fcaf6dd600959be498ce7745b6 (diff)
downloadaur-cd8dd777fcc7cb5866e2798d6a35a6697723ff2b.tar.gz
Build only for kernels before Linux 5.16
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
-rw-r--r--system76-acpi-dkms.conf9
4 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 770aca68b589..fbfc1cab614a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = system76-acpi-dkms
pkgdesc = This provides the system76_acpi in-tree driver for systems missing it.
pkgver = 1.0.2+4+gb49caa5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pop-os/system76-acpi-dkms
arch = x86_64
license = GPL
makedepends = git
depends = dkms
- conflicts = linux>=5.16
source = git+https://github.com/pop-os/system76-acpi-dkms.git#commit=b49caa557e6f902381ca76b6bb8f8a2825ad099b
+ source = system76-acpi-dkms.conf
sha256sums = SKIP
+ sha256sums = 23c2e7c1be0c97ec608f80958d68efbb3bb089ec6429f8ab273be65525df0aaf
pkgname = system76-acpi-dkms
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..4a3c0109480c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!system76-acpi-dkms.conf
diff --git a/PKGBUILD b/PKGBUILD
index 8908875cc198..2f2299a2f505 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-acpi-dkms
pkgver=1.0.2+4+gb49caa5
-pkgrel=2
+pkgrel=3
pkgdesc="This provides the system76_acpi in-tree driver for systems missing it."
arch=('x86_64')
url="https://github.com/pop-os/system76-acpi-dkms"
license=('GPL')
depends=('dkms')
makedepends=('git')
-conflicts=('linux>=5.16')
_commit=b49caa557e6f902381ca76b6bb8f8a2825ad099b
-source=("git+https://github.com/pop-os/system76-acpi-dkms.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("git+https://github.com/pop-os/system76-acpi-dkms.git#commit=$_commit"
+ "$pkgname.conf")
+sha256sums=('SKIP'
+ '23c2e7c1be0c97ec608f80958d68efbb3bb089ec6429f8ab273be65525df0aaf')
pkgver() {
cd "$srcdir/$pkgname"
@@ -35,7 +36,8 @@ package() {
install -Dm644 -t "$pkgdir/usr/lib/udev/hwdb.d/" lib/udev/hwdb.d/*
# Edit and install dkms configuration
- sed "s/#MODULE_VERSION#/${pkgver//+*/}/" "debian/system76-acpi-dkms.dkms" > "$install_dir/dkms.conf"
+ sed "s/#MODULE_VERSION#/${pkgver//+*/}/" \
+ "$srcdir/system76-acpi-dkms.conf" > "$install_dir/dkms.conf"
# Load the module at boot
install -Dm644 "usr/share/initramfs-tools/modules.d/$pkgname.conf" \
diff --git a/system76-acpi-dkms.conf b/system76-acpi-dkms.conf
new file mode 100644
index 000000000000..b9c442088913
--- /dev/null
+++ b/system76-acpi-dkms.conf
@@ -0,0 +1,9 @@
+PACKAGE_NAME="system76_acpi"
+PACKAGE_VERSION="#MODULE_VERSION#"
+AUTOINSTALL="yes"
+
+# Build only for kernels before Linux 5.16
+BUILD_EXCLUSIVE_KERNEL="^(5\.[0-9]\..*|4\.1[0-5]\..*|3\..*)"
+
+BUILT_MODULE_NAME[0]="system76_acpi"
+DEST_MODULE_LOCATION[0]="/updates/dkms"