summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2019-10-15 19:43:37 -0400
committerCorey Hinshaw2019-10-15 19:43:37 -0400
commitfbe4dc476b592e465bc02273c7c9f23c012aade5 (patch)
tree2525024b25b80603f2b0c3a0786b6e754679c313
downloadaur-fbe4dc476b592e465bc02273c7c9f23c012aade5.tar.gz
Initial commit - version 1.0.1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
-rw-r--r--system76-acpi.conf2
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36f781eb6ca8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = system76-acpi-dkms
+ pkgdesc = System76 ACPI Driver (DKMS)
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/pop-os/system76-acpi-dkms
+ arch = x86_64
+ license = GPL
+ depends = dkms
+ source = https://github.com/pop-os/system76-acpi-dkms/archive/1.0.1.tar.gz
+ source = system76-acpi.conf
+ sha256sums = 032fc6e0ba0ad6b94abb7f0f3dbc6126f8bdef3384d08be37823d684235c8e8d
+ sha256sums = 7b7e6bac10669d47576c8bd0bedad8217b32c1e25cab9cbb2ff64aa6be11fd39
+
+pkgname = system76-acpi-dkms
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cced017d91a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d75fee5e87dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
+
+pkgname=system76-acpi-dkms
+_pkgname=system76-acpi
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="System76 ACPI Driver (DKMS)"
+arch=('x86_64')
+url="https://github.com/pop-os/system76-acpi-dkms"
+license=('GPL')
+depends=('dkms')
+source=("https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
+ 'system76-acpi.conf')
+sha256sums=('032fc6e0ba0ad6b94abb7f0f3dbc6126f8bdef3384d08be37823d684235c8e8d'
+ '7b7e6bac10669d47576c8bd0bedad8217b32c1e25cab9cbb2ff64aa6be11fd39')
+
+
+package() {
+ # Installation directory
+ local install_dir="${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Install source files
+ for file in {Makefile,*.c,*.h}; do
+ [ -f "$file" ] || continue
+ install -D -m644 -t "${install_dir}/" "${file}"
+ done
+
+ # Edit and install dkms configuration
+ sed "s/#MODULE_VERSION#/${pkgver}/" "debian/system76-acpi-dkms.dkms" > "${install_dir}/dkms.conf"
+
+ # Load the module at boot
+ install -Dm644 ${srcdir}/${_pkgname}.conf ${pkgdir}/etc/modules-load.d/${_pkgname}.conf
+}
diff --git a/system76-acpi.conf b/system76-acpi.conf
new file mode 100644
index 000000000000..3cd89d70811c
--- /dev/null
+++ b/system76-acpi.conf
@@ -0,0 +1,2 @@
+# Load the System76 ACPI module
+system76-acpi