summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShaleen Jain2018-03-17 16:16:08 +0530
committerShaleen Jain2018-03-17 17:01:01 +0530
commitdda562bd56fe30f7ac0235af33729a241e8177c8 (patch)
tree6987e306ce2f29d55f6d6593c13a8992411da1fe
parent555b300ede739a1677983322bf57a8c30bf3e83a (diff)
downloadaur-dda562bd56fe30f7ac0235af33729a241e8177c8.tar.gz
install modules-load config
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
-rw-r--r--system76.conf2
3 files changed, 7 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cecc9fcd783a..37300320a164 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = system76-dkms-git
license = GPL2
makedepends = git
depends = dkms
+ conflicts = system76-dkms
source = system76::git+https://github.com/pop-os/system76-dkms.git#branch=dkms_bionic
source = dkms.conf
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ca4eee15cad5..07174ba9b42f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Shaleen Jain <shaleen(at)jain(dot)sh>
_pkgname=system76
+_pkgbase=system76-dkms
pkgname=system76-dkms-git
pkgver=48
pkgrel=1
@@ -35,4 +36,7 @@ package() {
# Copy sources (including Makefile)
cp ${_pkgname}/*.c ${install_dir}/
cp ${_pkgname}/Makefile ${install_dir}/Makefile
+
+ # Load the module at boot
+ install -Dm644 system76.conf ${pkgdir}/etc/modules-load.d/system76.conf
}
diff --git a/system76.conf b/system76.conf
new file mode 100644
index 000000000000..62481f7da20a
--- /dev/null
+++ b/system76.conf
@@ -0,0 +1,2 @@
+# Load the system76 driver module
+system76