summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-06 10:14:21 -0700
committerMark Wagie2023-11-06 10:14:21 -0700
commit1d4198cdab02ecff71d8b201ade0199d40c0b3b4 (patch)
tree09d51632181af0790851e3bd8c5dff9d3e3a7501
parentf0978e7a7c448310c6e31838ad57f6a0bd5fc0e0 (diff)
downloadaur-1d4198cdab02ecff71d8b201ade0199d40c0b3b4.tar.gz
20.04.82
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6750c89b772a..af8bfd8bea30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-driver
pkgdesc = Universal driver for System76 computers
- pkgver = 20.04.81
- pkgrel = 2
+ pkgver = 20.04.82
+ pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
arch = any
@@ -42,7 +42,7 @@ pkgbase = system76-driver
optdepends = system76-power: System76 Power Management
optdepends = xorg-xhost: To enable GUI applications on Wayland
optdepends = xorg-xbacklight: To use the backlight service
- source = git+https://github.com/pop-os/system76-driver.git#commit=ec593da4d8a94d6ca8b8b41ac0f753bf04b72ca6
+ source = git+https://github.com/pop-os/system76-driver.git#commit=dfbce5baac1900ab82138a3b55947b3816d6f181
source = cli.patch
source = wayland.patch
source = actions.patch
diff --git a/PKGBUILD b/PKGBUILD
index 5157ecce6796..4e4fa3fc5442 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: ava1ar <mail(at)ava1ar(dot)me>
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-driver
-pkgver=20.04.81
-pkgrel=2
+pkgver=20.04.82
+pkgrel=1
pkgdesc="Universal driver for System76 computers"
arch=('any')
url="https://github.com/pop-os/system76-driver"
@@ -27,7 +27,7 @@ optdepends=(
'xorg-xhost: To enable GUI applications on Wayland'
'xorg-xbacklight: To use the backlight service')
install="$pkgname.install"
-_commit=ec593da4d8a94d6ca8b8b41ac0f753bf04b72ca6 # tags/20.04.81^0
+_commit=dfbce5baac1900ab82138a3b55947b3816d6f181 # tags/20.04.82^0
source=(
"git+https://github.com/pop-os/system76-driver.git#commit=${_commit}"
'cli.patch'
@@ -40,12 +40,12 @@ sha256sums=('SKIP'
#validpgpkeys=('D3FB3AF9711C1CD12639C9F587F211AF2BE4C2FE') # Jeremy Soller (https://soller.dev) <jackpot51@gmail.com>
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
# patch for cli version - enable override vendor/model via /etc/system76-daemon.json
patch --no-backup-if-mismatch -Np1 -i "$srcdir/cli.patch"
@@ -66,12 +66,12 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
python -m installer --destdir="$pkgdir" dist/*.whl
# Install daemons and executables