summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2018-08-08 21:45:21 -0400
committerCorey Hinshaw2018-08-08 21:45:21 -0400
commit32b2716db84eaaabb2896b6a2c26eb5ffcf722ae (patch)
treeb0657e3800a2c8c9cdf3fef00051e34f996ba4ae
parentafcc1bafd00d13387dbb0bdaa563d567d8449cbf (diff)
downloadaur-32b2716db84eaaabb2896b6a2c26eb5ffcf722ae.tar.gz
Update to version 18.04.27
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
-rw-r--r--cli.patch4
-rw-r--r--com.system76.pkexec.system76-firmware.policy19
-rw-r--r--galu1.patch8
-rw-r--r--gtk.patch4
-rwxr-xr-xsystem76-firmware-pkexec2
-rw-r--r--system76-firmware.desktop.patch11
8 files changed, 32 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e7c01188fe..50c86bd78378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-driver
pkgdesc = System76 Driver provides drivers, restore, and regression support for System76 computers
- pkgver = 18.04.25
- pkgrel = 2
+ pkgver = 18.04.27
+ pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
arch = any
@@ -23,20 +23,14 @@ pkgbase = system76-driver
optdepends = polkit: Run System76 Driver GUI from application menu
optdepends = pulseaudio: To apply microphone fix
optdepends = xorg-xbacklight: To use the backlight service
- source = https://github.com/pop-os/system76-driver/archive/18.04.25.tar.gz
- source = system76-firmware-pkexec
- source = com.system76.pkexec.system76-firmware.policy
+ source = https://github.com/pop-os/system76-driver/archive/18.04.27.tar.gz
source = galu1.patch
source = gtk.patch
source = cli.patch
- source = system76-firmware.desktop.patch
- sha1sums = f017b987b0a55b1a21a1b45b167c8366f2134aa8
- sha1sums = a9dc6ba42eda0de7214b9c86e3914667354c142f
- sha1sums = 8e6a69a2610fdd3a21c06210e2ad183abe83430b
- sha1sums = ea8d53a80a26eb05b367f27996c8ce715aafba1e
- sha1sums = bf0c37a6226858c768e8ce2c9c3c3801aef14c0e
- sha1sums = 92f0de2acea6ac69c36378c7139fb84a7eaf7842
- sha1sums = ae28859f3f3ea58eff6ee3e0728bc0e70246af31
+ sha1sums = 83050ffc2ee8622e16792f32802c4e2bc6872783
+ sha1sums = ddc85f9b062eb89c2c6fef0c6d7c68a28f419760
+ sha1sums = 45b4601ed3d9d80a01d5179628b1502caa9d7e6f
+ sha1sums = 916e0eeda26e00bd0372c1ffc7c5368cda9d46a1
pkgname = system76-driver
diff --git a/PKGBUILD b/PKGBUILD
index fabb8ef3c786..bc77714fd6ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
pkgname=system76-driver
-pkgver=18.04.25
-pkgrel=2
+pkgver=18.04.27
+pkgrel=1
pkgdesc="System76 Driver provides drivers, restore, and regression support for System76 computers"
arch=('any')
url="https://github.com/pop-os/system76-driver"
@@ -32,27 +32,27 @@ optdepends=(
'xorg-xbacklight: To use the backlight service')
source=(
"https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
- 'system76-firmware-pkexec'
- 'com.system76.pkexec.system76-firmware.policy'
'galu1.patch'
'gtk.patch'
- 'cli.patch'
- 'system76-firmware.desktop.patch')
+ 'cli.patch')
sha1sums=(
- 'f017b987b0a55b1a21a1b45b167c8366f2134aa8'
- 'a9dc6ba42eda0de7214b9c86e3914667354c142f'
- '8e6a69a2610fdd3a21c06210e2ad183abe83430b'
- 'ea8d53a80a26eb05b367f27996c8ce715aafba1e'
- 'bf0c37a6226858c768e8ce2c9c3c3801aef14c0e'
- '92f0de2acea6ac69c36378c7139fb84a7eaf7842'
- 'ae28859f3f3ea58eff6ee3e0728bc0e70246af31')
+ '83050ffc2ee8622e16792f32802c4e2bc6872783'
+ 'ddc85f9b062eb89c2c6fef0c6d7c68a28f419760'
+ '45b4601ed3d9d80a01d5179628b1502caa9d7e6f'
+ '916e0eeda26e00bd0372c1ffc7c5368cda9d46a1')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- # Desktop shortcut for firmware tool should use pkexec wrapper
- patch -p0 < ${srcdir}/system76-firmware.desktop.patch
+ # patch for cli version - enable override vendor/model via /etc/system76-daemon.json
+ patch --no-backup-if-mismatch -Np1 -i ${srcdir}/cli.patch
+
+ # galu1 model-specific patch
+ patch --no-backup-if-mismatch -Np1 -i ${srcdir}/galu1.patch
+
+ # enabling "Restore System" button if all changes applied
+ patch --no-backup-if-mismatch -Np1 -i ${srcdir}/gtk.patch
}
package() {
@@ -67,7 +67,7 @@ package() {
install -m755 -D system76-firmware-dialog ${pkgdir}/usr/lib/${pkgname}/system76-firmware-dialog
install -m755 -D system76-driver-pkexec ${pkgdir}/usr/bin/system76-driver-pkexec
install -m755 -D system76-firmware ${pkgdir}/usr/bin/system76-firmware
- install -m755 -D ${srcdir}/system76-firmware-pkexec ${pkgdir}/usr/bin/system76-firmware-pkexec
+ install -m755 -D system76-firmware-pkexec ${pkgdir}/usr/bin/system76-firmware-pkexec
# Install systemd unit files
# Note: system76-driver* service files shortened to system76*
@@ -77,7 +77,7 @@ package() {
# Install scripts and configuration
install -m755 -D system76-nm-restart ${pkgdir}/usr/lib/${pkgname}/system76-nm-restart
install -m644 -D com.system76.pkexec.system76-driver.policy ${pkgdir}/usr/share/polkit-1/actions/com.system76.pkexec.system76-driver.policy
- install -m644 -D ${srcdir}/com.system76.pkexec.system76-firmware.policy ${pkgdir}/usr/share/polkit-1/actions/com.system76.pkexec.system76-firmware.policy
+ install -m644 -D com.system76.pkexec.system76-firmware.policy ${pkgdir}/usr/share/polkit-1/actions/com.system76.pkexec.system76-firmware.policy
# Install desktop shortcuts
install -m644 -D system76-driver-backlight.desktop ${pkgdir}/usr/share/applications/system76-backlight.desktop
@@ -88,16 +88,4 @@ package() {
# Clean up
rm -rf ${pkgdir}/usr/lib/python*/site-packages/system76driver/{__pycache__,tests}
-
- # Patch in package in place
- cd ${pkgdir}
-
- # patch for cli version - enable override vendor/model via /etc/system76-daemon.json
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/cli.patch
-
- # galu1 model-specific patch
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/galu1.patch
-
- # enabling "Restore System" button if all changes applied
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/gtk.patch
}
diff --git a/cli.patch b/cli.patch
index b3faabc8b7b2..22f351d6b7f9 100644
--- a/cli.patch
+++ b/cli.patch
@@ -1,5 +1,5 @@
---- a/usr/bin/system76-driver-cli 2016-03-05 15:53:48.000000000 -0500
-+++ b/usr/bin/system76-driver-cli 2016-03-05 18:03:49.068840665 -0500
+--- a/system76-driver-cli 2016-03-05 15:53:48.000000000 -0500
++++ b/system76-driver-cli 2016-03-05 18:03:49.068840665 -0500
@@ -27,6 +27,7 @@
import logging
diff --git a/com.system76.pkexec.system76-firmware.policy b/com.system76.pkexec.system76-firmware.policy
deleted file mode 100644
index 00d724823ede..000000000000
--- a/com.system76.pkexec.system76-firmware.policy
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE policyconfig PUBLIC
- "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
-<policyconfig>
-
- <action id="com.system76.pkexec.system76-firmware">
- <message>Authentication is required to run the System76 Firmware Updater</message>
- <icon_name>system76-driver</icon_name>
- <defaults>
- <allow_any>auth_admin</allow_any>
- <allow_inactive>auth_admin</allow_inactive>
- <allow_active>auth_admin</allow_active>
- </defaults>
- <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/system76-firmware</annotate>
- <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
- </action>
-
-</policyconfig>
diff --git a/galu1.patch b/galu1.patch
index b0db8eecf96a..6e82a01bd705 100644
--- a/galu1.patch
+++ b/galu1.patch
@@ -1,5 +1,5 @@
---- a/usr/lib/python3.6/site-packages/system76driver/daemon.py 2014-12-21 15:51:54.899761693 -0500
-+++ b/usr/lib/python3.6/site-packages/system76driver/daemon.py 2014-12-21 15:52:43.496397059 -0500
+--- a/system76driver/daemon.py 2014-12-21 15:51:54.899761693 -0500
++++ b/system76driver/daemon.py 2014-12-21 15:52:43.496397059 -0500
@@ -58,7 +58,6 @@
'bonx7',
'bonx8',
@@ -8,8 +8,8 @@
'gazp9',
'gazp9b',
'kudp1',
---- a/usr/lib/python3.6/site-packages/system76driver/model.py 2014-04-21 12:43:25.000000000 -0400
-+++ b/usr/lib/python3.6/site-packages/system76driver/model.py 2014-05-03 23:20:20.837535955 -0400
+--- a/system76driver/model.py 2014-04-21 12:43:25.000000000 -0400
++++ b/system76driver/model.py 2014-05-03 23:20:20.837535955 -0400
@@ -85,6 +85,7 @@
'K8N-DL': 'wilp2',
'KFN5-D SLI': 'wilp3',
diff --git a/gtk.patch b/gtk.patch
index 913fadbaafa5..a98af62eeda7 100644
--- a/gtk.patch
+++ b/gtk.patch
@@ -1,5 +1,5 @@
---- a/usr/lib/python3.6/site-packages/system76driver/gtk.py 2014-05-10 00:19:43.755367421 -0400
-+++ b/usr/lib/python3.6/site-packages/system76driver/gtk.py 2014-05-10 00:19:48.515363743 -0400
+--- a/system76driver/gtk.py 2014-05-10 00:19:43.755367421 -0400
++++ b/system76driver/gtk.py 2014-05-10 00:19:48.515363743 -0400
@@ -100,10 +100,10 @@
self.details.set_text('\n'.join(lines))
if self.action_runner.needed:
diff --git a/system76-firmware-pkexec b/system76-firmware-pkexec
deleted file mode 100755
index d7230560d2b0..000000000000
--- a/system76-firmware-pkexec
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-pkexec "/usr/bin/system76-firmware" --reinstall
diff --git a/system76-firmware.desktop.patch b/system76-firmware.desktop.patch
deleted file mode 100644
index a7ca02c5e36d..000000000000
--- a/system76-firmware.desktop.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- system76-firmware.desktop 2018-06-27 16:13:07.000000000 -0700
-+++ system76-firmware.desktop.new 2018-07-03 12:35:44.613934967 -0700
-@@ -4,7 +4,7 @@
- Name=System76 Firmware Updater
- GenericName=System76 Firmware Updater
- Comment=Updates Firmware on System76 Systems
--Exec=system76-firmware --reinstall
-+Exec=system76-firmware-pkexec --reinstall
- Terminal=false
- Type=Application
- Icon=system76-driver