summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2025-01-23 15:44:37 -0700
committerMark Wagie2025-01-23 15:44:37 -0700
commit33c7f7704da2ed8b7adf5d481ce1b031384adc39 (patch)
tree4f3b64fd21d475534bfc7a5655f25ffe994adc17
parentaedadc273d5a59ea2691c08ed9088a92ea4e7276 (diff)
downloadaur-33c7f7704da2ed8b7adf5d481ce1b031384adc39.tar.gz
20.04.108
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore8
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD32
-rw-r--r--products.patch162
5 files changed, 194 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad1719b10690..b2430ec1a7f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-driver
pkgdesc = Universal driver for System76 computers
- pkgver = 20.04.107
+ pkgver = 20.04.108
pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
@@ -42,11 +42,13 @@ pkgbase = system76-driver
optdepends = system76-power: System76 Power Management
optdepends = xorg-xhost: To enable GUI applications on Wayland
optdepends = xorg-xbacklight: To use the backlight service
- source = git+https://github.com/pop-os/system76-driver.git#tag=20.04.107
+ source = git+https://github.com/pop-os/system76-driver.git#tag=20.04.108
source = cli.patch
source = actions.patch
- sha256sums = 5fba0d8e2d23cd47a640e3bc840aaf1e984472c397525543a6a4bd56efec96a0
+ source = products.patch
+ sha256sums = c37afcaf433fbe66922f7001ec584a1a698e4119d9909587c418381e94e955f6
sha256sums = ef027346c439561dc01f906ae7bd961100aedf9125fd86bb0eb89a87b683fdc3
sha256sums = 3ade740c1681f8f33ef78e1e6c087e4002d14c888d7a5bf6bfbeb2aa70111119
+ sha256sums = c80118ff9f93d63bda50180950f631661b7882f11821387f813f2f95eeeccbcb
pkgname = system76-driver
diff --git a/.gitignore b/.gitignore
index 51dfc06f5ec2..c71b32af45f1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,11 +1,13 @@
# Ignore everything
-*
+/*
# But not these files...
!.gitignore
!PKGBUILD
!.SRCINFO
+!.nvchecker.toml
+!LICENSE
+!system76-driver.install
!actions.patch
!cli.patch
-!system76-driver.install
-!.nvchecker.toml
+!products.patch
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..733e88560b9d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license. They are provided under the license terms of the software they describe changes for.
+
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
+
+Copyright 2024 Arch Linux Contributors
+
+Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.
+
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index adba2a64be32..83ee0efa957e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: ava1ar <mail(at)ava1ar(dot)me>
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-driver
-pkgver=20.04.107
+pkgver=20.04.108
pkgrel=1
pkgdesc="Universal driver for System76 computers"
arch=('any')
@@ -49,34 +49,28 @@ optdepends=(
'xorg-xhost: To enable GUI applications on Wayland'
'xorg-xbacklight: To use the backlight service'
)
-checkdepends=(
- 'python-pytest'
-)
+checkdepends=('python-pytest')
install="$pkgname.install"
-source=(
- "git+https://github.com/pop-os/system76-driver.git#tag=$pkgver"
- 'cli.patch'
- 'actions.patch')
-sha256sums=('5fba0d8e2d23cd47a640e3bc840aaf1e984472c397525543a6a4bd56efec96a0'
+source=("git+https://github.com/pop-os/system76-driver.git#tag=$pkgver"
+ 'cli.patch'
+ 'actions.patch'
+ 'products.patch')
+sha256sums=('c37afcaf433fbe66922f7001ec584a1a698e4119d9909587c418381e94e955f6'
'ef027346c439561dc01f906ae7bd961100aedf9125fd86bb0eb89a87b683fdc3'
- '3ade740c1681f8f33ef78e1e6c087e4002d14c888d7a5bf6bfbeb2aa70111119')
+ '3ade740c1681f8f33ef78e1e6c087e4002d14c888d7a5bf6bfbeb2aa70111119'
+ 'c80118ff9f93d63bda50180950f631661b7882f11821387f813f2f95eeeccbcb')
prepare() {
cd "$pkgname"
# patch for cli version - enable override vendor/model via /etc/system76-daemon.json
- patch --no-backup-if-mismatch -Np1 -i "$srcdir/cli.patch"
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir/cli.patch"
# Use mkinitcpio instead of initramfs-tools
- patch --no-backup-if-mismatch -Np1 -i "$srcdir/actions.patch"
-
- # Force Composition Pipeline no longer necessary
- sed -i '/ actions.nvidia_forcefullcompositionpipeline,/d' \
- system76driver/products.py
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir/actions.patch"
- # Blacklisting nvidia_i2c accomplishes nothing
- sed -i '/ actions.blacklist_nvidia_i2c,/d' \
- system76driver/products.py
+ # Do not blacklist nvidia_i2c, do not Force Composition Pipeline
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir/products.patch"
}
build() {
diff --git a/products.patch b/products.patch
new file mode 100644
index 000000000000..2016169ab373
--- /dev/null
+++ b/products.patch
@@ -0,0 +1,162 @@
+diff --unified --recursive --text a/system76driver/products.py b/system76driver/products.py
+--- a/system76driver/products.py 2025-01-23 15:36:20.284188996 -0700
++++ b/system76driver/products.py 2025-01-23 15:36:53.480420092 -0700
+@@ -29,26 +29,22 @@
+ 'addw1': {
+ 'name': 'Adder WS',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ ],
+ },
+ 'addw2': {
+ 'name': 'Adder WS',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ ],
+ },
+ 'addw3': {
+ 'name': 'Adder WS',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.remove_blacklist_psmouse,
+ ],
+ },
+ 'addw4': {
+ 'name': 'Adder WS',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.remove_blacklist_psmouse,
+ ],
+ },
+@@ -358,56 +354,48 @@
+ 'gaze14': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i8042_nomux,
+ ],
+ },
+ 'gaze15': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i8042_nomux,
+ ],
+ },
+ 'gaze16-3050': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.blacklist_psmouse,
+ ],
+ },
+ 'gaze16-3060': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.blacklist_psmouse,
+ ],
+ },
+ 'gaze16-3060-b': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.blacklist_psmouse,
+ ],
+ },
+ 'gaze17-3050': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.blacklist_psmouse,
+ ],
+ },
+ 'gaze17-3060-b': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.blacklist_psmouse,
+ ],
+ },
+ 'gaze18': {
+ 'name': 'Gazelle',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.remove_blacklist_psmouse,
+ ],
+ },
+@@ -769,27 +757,23 @@
+ 'name': 'Oryx Pro',
+ 'drivers': [
+ actions.hda_probe_mask,
+- actions.blacklist_nvidia_i2c,
+ ],
+ },
+ 'oryp6': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ ],
+ },
+ 'oryp7': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ ],
+ },
+ 'oryp8': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.blacklist_psmouse,
+ actions.i915_initramfs,
+ ],
+@@ -797,7 +781,6 @@
+ 'oryp9': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ actions.blacklist_psmouse,
+ ],
+@@ -805,7 +788,6 @@
+ 'oryp10': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ actions.blacklist_psmouse,
+ ],
+@@ -813,7 +795,6 @@
+ 'oryp11': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ actions.remove_blacklist_psmouse,
+ ],
+@@ -821,7 +802,6 @@
+ 'oryp12': {
+ 'name': 'Oryx Pro',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ actions.remove_blacklist_psmouse,
+ ],
+@@ -1092,14 +1072,12 @@
+ 'drivers': [
+ actions.firefox_framerate144,
+ actions.firefox_unsetwebrender,
+- actions.nvidia_forcefullcompositionpipeline,
+ actions.i8042_nomux,
+ ],
+ },
+ 'serw13': {
+ 'name': 'Serval WS',
+ 'drivers': [
+- actions.blacklist_nvidia_i2c,
+ actions.i915_initramfs,
+ actions.remove_blacklist_psmouse,
+ ],