summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2020-04-01 19:35:22 -0400
committerCorey Hinshaw2020-04-01 19:35:22 -0400
commitd41f720146473a67b5a530883058d8713a96d0df (patch)
tree01ddf1f06a7f33c6978918af71252f9c70a23a6c
parenteaeb923382f7c6767a1dabe716d08016c3d9a264 (diff)
downloadaur-d41f720146473a67b5a530883058d8713a96d0df.tar.gz
Update to version 20.04.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
-rw-r--r--gtk.patch14
-rw-r--r--os.patch24
-rw-r--r--system76-driver.install14
5 files changed, 18 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c97003d938dc..60238daeb6b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-driver
pkgdesc = Universal driver for System76 computers
- pkgver = 19.10.2
+ pkgver = 20.04.3
pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
@@ -8,10 +8,10 @@ pkgbase = system76-driver
license = GPL
depends = at
depends = dmidecode
- depends = firmware-manager
depends = python>=3.6
depends = python-cffi
depends = python-dbus
+ depends = python-distro
depends = python-evdev
depends = python-gobject
depends = python-pynacl
@@ -20,6 +20,7 @@ pkgbase = system76-driver
depends = system76-acpi-dkms
depends = system76-dkms
depends = system76-firmware-daemon
+ optdepends = firmware-manager: Manage System76 firmware updates
optdepends = gtk3: To launch System76 driver and firmware GUI
optdepends = pm-utils: For power management features
optdepends = polkit: Run System76 Driver GUI from application menu
@@ -29,18 +30,14 @@ pkgbase = system76-driver
optdepends = system76-power: System76 Power Management
optdepends = xorg-xhost: To enable GUI applications on Wayland
optdepends = xorg-xbacklight: To use the backlight service
- source = https://github.com/pop-os/system76-driver/archive/19.10.2.tar.gz
+ source = https://github.com/pop-os/system76-driver/archive/20.04.3.tar.gz
source = galu1.patch
- source = gtk.patch
source = cli.patch
source = wayland.patch
- source = os.patch
- sha1sums = bc1aed472cc05542b8aa4c940ef4db92f8bd146e
+ sha1sums = fdcc2d8d68cdca22609537e035d82450db1c3c65
sha1sums = ddc85f9b062eb89c2c6fef0c6d7c68a28f419760
- sha1sums = 45b4601ed3d9d80a01d5179628b1502caa9d7e6f
sha1sums = 916e0eeda26e00bd0372c1ffc7c5368cda9d46a1
sha1sums = 4825b80d13555742c30d197e4de56638eef162e6
- sha1sums = 0134ec37bfc874bd544a89c48124a03241af2aa4
pkgname = system76-driver
diff --git a/PKGBUILD b/PKGBUILD
index 53d70088755d..4a23161faa1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-driver
-pkgver=19.10.2
+pkgver=20.04.3
pkgrel=1
pkgdesc="Universal driver for System76 computers"
arch=('any')
@@ -12,10 +12,10 @@ install="${pkgname}.install"
depends=(
'at'
'dmidecode'
- 'firmware-manager'
'python>=3.6'
'python-cffi'
'python-dbus'
+ 'python-distro'
'python-evdev'
'python-gobject'
'python-pynacl'
@@ -27,6 +27,7 @@ depends=(
makepdepends=(
'python-pyflakes')
optdepends=(
+ 'firmware-manager: Manage System76 firmware updates'
'gtk3: To launch System76 driver and firmware GUI'
'pm-utils: For power management features'
'polkit: Run System76 Driver GUI from application menu'
@@ -39,17 +40,13 @@ optdepends=(
source=(
"https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
'galu1.patch'
- 'gtk.patch'
'cli.patch'
- 'wayland.patch'
- 'os.patch')
+ 'wayland.patch')
sha1sums=(
- 'bc1aed472cc05542b8aa4c940ef4db92f8bd146e'
+ 'fdcc2d8d68cdca22609537e035d82450db1c3c65'
'ddc85f9b062eb89c2c6fef0c6d7c68a28f419760'
- '45b4601ed3d9d80a01d5179628b1502caa9d7e6f'
'916e0eeda26e00bd0372c1ffc7c5368cda9d46a1'
- '4825b80d13555742c30d197e4de56638eef162e6'
- '0134ec37bfc874bd544a89c48124a03241af2aa4')
+ '4825b80d13555742c30d197e4de56638eef162e6')
build() {
@@ -61,14 +58,8 @@ build() {
# galu1 model-specific patch
patch --no-backup-if-mismatch -Np1 -i ${srcdir}/galu1.patch
- # enabling "Restore System" button if all changes applied
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/gtk.patch
-
# Use xhost for GUI apps on Wayland
patch --no-backup-if-mismatch -Np1 -i ${srcdir}/wayland.patch
-
- # platform.dist() removed in Python 3.8. Hardcode OS instead.
- patch --no-backup-if-mismatch -Np1 -i ${srcdir}/os.patch
}
package() {
@@ -89,10 +80,11 @@ package() {
# Install scripts and configuration
install -m755 -D system76-nm-restart ${pkgdir}/usr/lib/${pkgname}/system76-nm-restart
+ install -m755 -D system76-thunderbolt-reload ${pkgdir}/usr/lib/${pkgname}/system76-thunderbolt-reload
install -m644 -D com.system76.pkexec.system76-driver.policy ${pkgdir}/usr/share/polkit-1/actions/com.system76.pkexec.system76-driver.policy
# Install application launchers
- install -m644 -D system76-driver-backlight.desktop ${pkgdir}/usr/share/applications/system76-backlight.desktop
+ install -m644 -D system76-driver-backlight.desktop ${pkgdir}/etc/xdg/autostart/system76-backlight.desktop
# Create /var/lib/system76-driver directory for brightness settings saving
install -m755 -d ${pkgdir}/var/lib/${pkgname}
diff --git a/gtk.patch b/gtk.patch
deleted file mode 100644
index a98af62eeda7..000000000000
--- a/gtk.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/system76driver/gtk.py 2014-05-10 00:19:43.755367421 -0400
-+++ b/system76driver/gtk.py 2014-05-10 00:19:48.515363743 -0400
-@@ -100,10 +100,10 @@
- self.details.set_text('\n'.join(lines))
- if self.action_runner.needed:
- self.enabled['driverInstall'] = True
-- self.enabled['driverRestore'] = True
- else:
- msg = _('All drivers have been applied, nothing to do.')
- self.set_notify('gtk-ok', msg)
-+ self.enabled['driverRestore'] = True
- self.set_sensitive(True)
-
- def set_sensitive(self, sensitive):
diff --git a/os.patch b/os.patch
deleted file mode 100644
index dab1f704ff82..000000000000
--- a/os.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/system76-driver 2020-01-15 10:51:43.000000000 -0500
-+++ b/system76-driver 2020-01-20 22:09:04.666956825 -0500
-@@ -59,7 +59,7 @@
-
- log.info('** Process start at monotonic time %r', time.monotonic())
- log.info('system76driver.__version__: %r', system76driver.__version__)
--log.info('OS: %r', platform.dist())
-+log.info('OS: Arch Linux')
- log.info('kernel: %r', platform.uname().release)
- log.info('model: %r', args.model)
-
---- a/system76driver/gtk.py 2020-01-20 21:50:46.812227180 -0500
-+++ b/system76driver/gtk.py 2020-01-20 22:19:02.673782867 -0500
-@@ -53,9 +53,7 @@
- self.notify_text = self.builder.get_object('notifyLabel')
- self.details = self.builder.get_object('detailsText')
- self.builder.get_object('sysModel').set_text(model)
-- self.builder.get_object('ubuntuVersion').set_text(
-- '{} {} ({})'.format(*platform.dist())
-- )
-+ self.builder.get_object('ubuntuVersion').set_text('Arch Linux')
- self.builder.get_object('driverVersion').set_text(__version__)
-
- self.builder.connect_signals({
diff --git a/system76-driver.install b/system76-driver.install
index cde9866d5947..ee779fed9ab1 100644
--- a/system76-driver.install
+++ b/system76-driver.install
@@ -34,23 +34,18 @@ cat << EOF
system76-backlight.service Backlight Daemon for NVIDIA 9 Series on GNOME
- The backlight service can (optionally) be started automatically:
-
- ln -s /usr/share/applications/system76-driver-backlight.desktop /etc/xdg/autostart/system76-driver-backlight.desktop
-
- GUI applications are provided to install drivers, patches, and firmware updates.
-
(!) To use system76.service, you must add "ec_sys.write_support=1" to your kernel command line
(!) For Clevo W740SU BIOS/Firmware users on Galago UltraPro: your will need to create /etc/system76-daemon.json
- file with following content:
+ file with following content:
{ "vendor": "System76, Inc", "model": "galu1" }
- (!) If you experience Wifi issues after resuming from suspend, consider using the included network
- restart script:
+ (!) If you experience Wifi or Thunderbolt issues after resuming from suspend, consider using the
+ included restart scripts:
ln -s /usr/lib/system76-driver/system76-nm-restart /lib/systemd/system-sleep/system76-nm-restart
+ ln -s /usr/lib/system76-driver/system76-thunderbolt-reload /lib/systemd/system-sleep/system76-thunderbolt-reload
EOF
}
@@ -72,6 +67,7 @@ pre_remove() {
# Remove symlinks if target points to package files
_remove_symlink /etc/xdg/autostart/system76-driver-backlight.desktop /usr/share/applications/system76-driver-backlight.desktop
_remove_symlink /lib/systemd/system-sleep/system76-nm-restart /usr/lib/system76-driver/system76-nm-restart
+ _remove_symlink /lib/systemd/system-sleep/system76-thunderbolt-reload /usr/lib/system76-driver/system76-thunderbolt-reload
}
post_remove() {